coexistence 2010/2016 access to EAC 2016 when mailbox is in 2010

Copper Contributor

Hello All,


Problem:-  During coexistence 2010/2016, you use your administrator login to access the new EAC 2016, but you get redirected to ECP 2010.


I appreciate any feedback and if you can actually replicate this issue in your test lab and share your findings.


I know that if the administrator account is still located in a database that is not on Exchange 2016, you must use the specially formed URL to route the administrator to EAC -> (/ecp?ExchClientVer=15),  lets just say you don't want to change DNS settings yet and just want to have a look at the EAC after introducing your new 2016 Exchange servers to your existing 2010 organization and mailboxes are still in 2010. 


So I created an admin account with a mailbox via EMC in my exchange 2010 and added it to organizational management role, server management, public folder management, view-only, recipient management roles , and that's all.


I went over to my Exchange 2016, opened internet explorer in-private browsing used the URL (/ecp?ExchClientVer=15) to login to EAC, but after loading it redirects me still to ECP 2010, i tried this a few times, the URL is correct, i type it in myself, still it keeps redirecting to ECP 2010, restart owaapppool, iis, reboot server, flushdns - still redirects to 2010.


So I went back to 2010 server, I checked the admin account in AD and the membership role i assigned, then i added 'discovery management role' to the account, which I did not add previously. I went back to Exchange 2016 and on the first attempt using the URL (/ecp?ExchClientVer=15), EAC 2016 opens successfully, no more redirecting to ECP 2010. 


So, I go back to my admin AD account, removed the discovery management role, flushdns cache in Exchange 2016 server, restart owaapppool, use internet explorer in private browsing, tried to login to EAC 2016 - Again, problem returns and I am redirected to ECP 2010.  I repeated above 2 steps again and again and its the same results each time.


Any expert knowledge why the 'discovery management role' ?

3 Replies
Doesn't click, must be some bug.
Try this if you notice any change

I can only imagine that permission inheritance is blocked on that (admin) user object you try to access ECP.


Are you running the latest RU and CU updates?

Maybe the account is a member of a AdminSDHolder security group?