Changing Teams meeting on-prem breaks time zone

Occasional Contributor

Hi,

 

we do have an Exchange Hybrid Setup. On-Prem we do use OWA only. No Outlook-Client.

 

When a user creates a Teams meeting (inside the Teams calendar) they sometimes use OWA when changing the meeting for comfort reasons (drag&drop). Here the problems begin.

 

A little example:

- User sets up meeting at 11:00 a.m. within the Teams calendar.

- User changes meeting to 9:00 a.m. via OWA on the Exchange on-prem

- Within in the organisation, everything is OK. But every External now has the appointment at 1:00 p.m.

 

So somehow Exchange does a +2h (summertime maybe involved) to the orginal starting time of the meeting. But just for external participants. Inside the organisation everything is fine. Exchange always does the +2h based from the original meeting starttime. So moving the appointment to 3:00 p.m. will also lead to 1 p.m. for the External.

 

Technically the .ics gets changed from "W. Europe Standard Time" to "UTC".

 

If we change the meeting in the Teams calendar, everything is fine. If you create the meeting On-Prem and change it On-Prem or in the Teams calendar, everything is fine. It is just Online created meetings, changed On-Prem what causes the issue.

 

I attached a screenshot of the .ics file. Right side shows the original meeting from Teams. Left side shows the changes of the meeting after leaving Exchange On-Prem.

 

Does anybody have an idea where to look?

 

Cheers Sebastian

1 Reply

Hi @Sebastian_Rottmann,

 

this looks like a bug in the MS construct itself.

 

I have no idea how to fix it. You should create a MS Support case.

 

Best regards,
Schnittlauch

"First, No system is safe. Second, Aim for the impossible. Third, no Backup, no Mercy" - Schnittlauch

My answer helped you? Don't forget to leave a like. Also mark the answer as solved when your problem is solved. :)