Cannot send emails with shared mailbox

Brass Contributor

 

Hi, 

 

I'm having strange behaviour with one of my shared mailboxes (ie mailbox2)

Users with full access to this mailbox can reply as mailbox2, but they cannot send emails as mailbox2. I have tested with 2 users on seperate computers and both of them have the same problem.

 

I have an older mailbox1 shared mailbox that works perfectly... Now I've tried to create another shared mailbox called mailbox3 and is now having the same problem... 

 

I have compared mailbox1 with mailbox2 in Powershell and they have exactly the same permissions. (FullAccess)

 

To clarify further... I CAN SEND EMAILS with the problematic mailbox HOWEVER I need to follow the following steps: "New email" => click "From" => I CANNOT select the problematic email adress here or CANNOT type the emailaddress here because mailing will fail, INSTEAD I MUST click "other email address" => click "from" again => search for the correct mailaddress in global address list => select the mailaddress => click OK => click OK

 

If I follow the steps above, I can send emails perfectly... BUT my users would like to select the email from the dropdown in the FROM box when writing a new email or simply type it in. Selecting or typing the email here always causes sending email to fail.

 

Any Idea what this could be?

I have tried to clear the cache of local outlook client, I have tried to manually add the shared mailbox, compared permissions with a working shared mailbox... No Luck...

 

I immediately get following reply when sending the mail:

__________________________________________--------------------------------------------
Van: Systeembeheerder
Verzonden: woensdag 26 april 2023 14:14
Onderwerp: Onbestelbaar: testt


Uw bericht heeft enkele of alle geadresseerden niet bereikt.

Onderwerp: testt
Verzonden: 26/04/2023 14:14

De volgende geadresseerde(n) zijn niet bereikt:

E op 26/04/2023 14:14
Dit bericht is niet verzonden. U bent niet gemachtigd om het bericht namens de opgegeven gebruiker te verzenden.

__________________________________________________

Diagnostische gegevens voor beheerders:
__________________________________________________

Fout is [0x80070005-0x000004dc-0x00000524].

Exchange-antwoordheaders:
request-id: 99d633b6-cfc5-da09-e93e-bcf5ba0389ff
X-ServerApplication: Exchange/15.20.6340.019
X-FEServer: AM0PR05CA0082
X-BEServer: PAWPR10MB7367
X-CalculatedBETarget: PAWPR10MB7367.EURPRD10.PROD.OUTLOOK.COM
X-RequestId: {1E79AF9A-71ED-4B64-81A1-DEC86709DFFF}:107
X-ClientInfo: {50913F54-B756-48CF-B936-19FE401ABF76}:413520035
X-ElapsedTime: 93
X-BackEndHttpStatus: 200
X-ResponseCode: 0
X-DiagInfo: PAWPR10MB7367
X-RequestType: Execute
__________________________________________________

Overzicht van externe bewerkingen:

0: ropSetProps (10) Verwerkt(1) Voltooid(0)
Resultaat van externe bewerkingen: 0
Reactiecodes: 0
1: ropSetProps (10) Verwerkt(1) Voltooid(0)
Resultaat van externe bewerkingen: 0
Reactiecodes: 0
2: ropFlushRecipients (14) Verwerkt(1) Voltooid(0)
Resultaat van externe bewerkingen: 0
Reactiecodes: 0
3: ropSetProps (10) Verwerkt(1) Voltooid(0)
Resultaat van externe bewerkingen: 0
Reactiecodes: 0
4: ropTransportSend (74) Verwerkt(1) Voltooid(0)
Resultaat van externe bewerkingen: 0
Reactiecodes: 1244
__________________________________________________

Uitzonderingen bij reacties:

Index van externe bewerkingen: 4
Gekoppelde externe bewerkingen: ropTransportSend (74)
Microsoft.Exchange.Data.Storage.SendAsDeniedException: Can't send message. ---> Microsoft.Mapi.MapiExceptionSendAsDenied: MapiExceptionSendAsDenied: Unable to send message. (hr=0x80070005, ec=1244)
0.35250:25020000, 1.36674:01000000, 1.61250:00000000, 1.45378:02000000, 1.44866:00000000, 1.36674:01000000, 1.61250:00000000, 1.45378:05000000, 1.44866:00000000, 1.36674:7A000000, 1.61250:00000000, 1.45378:08000000, 1.44866:00140000, 1.36674:0A000000, 1.61250:00000000, 1.45378:19000000, 1.44866:E00C0000, 1.36674:0E000000, 1.61250:00000000, 1.45378:FC0C0000, 1.44866:F5010000, 16.55847:BC0A0000, 17.43559:0000000034020000000000000000000000000000, 20.52176:140FC498130000101F000130, 20.50032:140FC4988317F01FA4000000, 0.53414:12000000, 0.35180:14000000, 255.23226:15000000, 255.27962:7A000000, 255.27962:0A000000, 255.27962:0E000000, 255.31418:03000136, 0.35250:65020000, 1.36674:0A000000, 1.61250:00000000, 1.45378:02000000, 1.44866:1A000000, 1.36674:4A000000, 1.61250:00000000, 1.45378:1F000000, 1.44866:00000000, 16.55847:80000000, 17.43559:00000000A8030000000000000000000000000000, 20.52176:140FC498130000000A000A80, 20.50032:140FC498831770200A007100, 0.53414:03000B67, 0.35180:83020000, 255.23226:0A00CE80, 255.27962:0A000000, 255.27962:4A000000, 255.17082:DC040000, 0.44949:0A004366, 4.21921:DC040000, 255.27962:FA000000, 255.1494:1F000430, 0.38698:86000000, 1.41134:46000000, 0.37692:86000000, 0.37948:86000000, 5.33852:00000000534D545000010480, 4.56248:DC040000, 7.40748:010000000000010B05000780, 7.57132:000000000000000005000780, 4.39640:DC040000, 1.63016:4A000000, 8.45434:7E20EB1B33BC6E4798ED714B403F2F4B00000000, 1.46798:13000000, 5.10786:0000000031352E32302E363334302E3031393A504157505231304D42373336373A66653361616261382D653762332D343630372D616561392D6333386437366639326236343A3134383437363A2E4E455420362E302E313600000000, 7.51330:6B8CDFB34F46DB0886000000, 0.39570:86000000, 1.55954:0A000000, 1.33010:0A000000, 2.54258:00000000, 0.40002:00000000, 1.56562:00000000, 1.33010:0A000000, 2.54258:00000000, 0.40002:00000000, 1.56562:00000000, 1.64146:4A000000, 1.33010:4A000000, 2.54258:DC040000, 1.33010:4A000000, 2.54258:DC040000, 255.1750:0A004E0E, 255.31418:0A003267, 0.22753:E2020000, 255.21817:DC040000, 0.34722:0A001870, 4.51106:DC040000, 0.41890:0A00773A, 4.58274:DC040000, 0.59285:EC020000, 4.46997:DC040000
at Microsoft.Mapi.MapiExceptionHelper.InternalThrowIfErrorOrWarning(String message, Int32 hresult, Boolean allowWarnings, Int32 ec, DiagnosticContext diagCtx, Exception innerException, MapiStore mapiStore)
at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, IExInterface iUnknown, Exception innerException, MapiStore mapiStore)
at Microsoft.Mapi.MapiBase.ThrowIfError(String message, Int32 hr)
at Microsoft.Mapi.MapiMessage.TransportSendMessage(PropValue[]& propsToReturn)
at Microsoft.Exchange.Data.StoreObjects.MapiAccessorExtensionMethods.TransportSendMessage(IStoreSession storeSession, Object mapiObject, ExTimeZone timezone, PropValue[]& mapiPropValues)
--- End of inner exception stack trace ---
at Microsoft.Exchange.Data.StoreObjects.MapiAccessorExtensionMethods.TransportSendMessage(IStoreSession storeSession, Object mapiObject, ExTimeZone timezone, PropValue[]& mapiPropValues)
at Microsoft.Exchange.Data.Storage.CoreItem.TransportSend(PropertyDefinition[]& properties, Object[]& values)
at Microsoft.Exchange.RpcClientAccess.Handler.Message.TransportSend()
at Microsoft.Exchange.RpcClientAccess.Handler.RopHandler.<>c__DisplayClass156_0.<TransportSend>b__0()
at Microsoft.Exchange.RpcClientAccess.Handler.ExceptionTranslator.TryExecuteCatchAndTranslateExceptions[TResult](Func`1 protectedCode, Func`2 errorCodeExtractor, Boolean noThrow, TResult& result, Exception& exception, ErrorCode& errorCode)


Transportverzending is mislukt: foutopsomming(25), HResult(0x00000000), EC(1244).
Transportverzending is mislukt: foutopsomming(22), HResult(0x00000000), EC(1244).
Berichtverzending is mislukt: bericht-id(2), foutopsomming(13), HResult(0x80070005), EC(1244).

 

4 Replies
Full Access permissions do not give you rights to send messages via the shared mailbox. For that to work, you need either Send As or Send on behalf of.
Thanks for the response Vasil.
Permission is added in "Send As".
with FullAccess I was referring to the AccessRights shown in Powershell when performing Get-MailboxPermissions... In Powershell it only shows "FullAccess", yet with one mailadres I'm able to send an email while with the other I'm only able to send via the described workaround...

Hello everyone,
is there any update? I am facing the same issue for newly created shared mailboxes, however old ones are working fine.

I have full access to read and manage as well as send as permissions.

 

Thank you.