Cannot display the folder

Copper Contributor

We have 1 user that has a weird issue sometimes when they access another user mailbox (shared with others) from a favourite shotcut, where the message window is completely blank with just the words: Cannot display the folder.  Please see attached.


If they click away from the mailbox and leave it a while and come back the content is displayed.  The issue is totally random and cannot be re-produced on demand.


We have re-built the laptop but the issue still exists and presents on multiple devices.  I am migrating the mailbox to a new DB to see if this helps.


I am leaning towards a user account / mailbox problem but we have tried everything and are now stumped.  Has anyone else ever seen this?  Suggestions / help please.




2 Replies



Is the behaviour same in Webmail as well?


How was the delegate access access granted? Is it via Outlook Client or Full Mailbox Access via EAC or PowerShell





If I have answered your question, please mark your post as Solved

If you like my response, please give it a Like :smile:

Appreciate your Kudos! Proud to contribute! :)






We give Full Mailbox Access via EAC.  Our users do not like using webmail, so cannot comment on that.  Odd thing with this user is it will happen on multiple laptops at random times.