554 5.2.0 Error - AdditionalRenEntryIdsEx is too large and requires streaming

Copper Contributor



We are using Exchange Online in a hybrid environment with Exchange 2016 (Version 15.1 ‎Build 2375.7)‎


We are experiencing a recurring 554 error with specific users. The error seems to occur only with reply emails that contain symbols in the subject. So, for example, if a user replies to a message and Outlook adds 'RE:', the error will occur. After removing the ':', the reply will go through with no problem. The error seems to come and go on its own, sometimes resolving itself before we can dig deeper. And, so far, it only happens with the same handful of users.


Remote Server returned '554 5.2.0 STOREDRV.Deliver.Exception:StoragePermanentException.PropertyTooBigException; Failed to process message due to a permanent exception with message [BeginDiagnosticData]Exception encountered initializing default folder. PropertyTooBigException:
The object data is corrupted. The value of property [0x36d90102] AdditionalRenEntryIdsEx is too large and requires streaming.[EndDiagnosticData] [Stage: OnPromotedEvent][Agent: Conversations Processing Agent]'


So far, we have tried the following fixes (some of these were done before we discovered it was an issue with symbols in the subject line)

  • Clear all rules from the mailbox
  • Remove any unneeded Office add-ins
  • Running the Disable-RemoteMailbox command, waiting for the mailbox to show up as soft-deleted, then running Enable-RemoteMailbox
  • Moving the mailbox to a different database using New-MoveRequest
  • Removing any attachments from the message
  • Formatting the message as plain text

Looking on the interwebs, I've not seen any other reports of this exact error—plenty of 554 5.2.0 errors but none with this same diag data.

Ideas or suggestions would be appreciated. 


5 Replies
We have the exact same issue. How did you resolved this?

@Roel80 Thanks for the reply. It is good to know we are not alone in this.

We opened a ticket with Microsoft, and after mover 2 months, we still do not have a solution. Our only temporary solution is to delete the faulty record on the user's mailbox using MFCMAPI. This seems to work for a few weeks or more, then the issue reappears.


Microsoft suggested starting Outlook with the command Outlook.exe /CleanConvOnGoingActions as referenced here Messages in an e-mail thread are automatically moved to the Deleted Items folder - Microsoft Support. This was after informing them the issue referenced in the article did not match ours.


We just got a new ticket for the same issue on a mailbox we ran that command on....I'll post an update once Microsoft responds.

@USC_IT Thanks for your reply.
We also received today this solution:
Configure user's profile in outlook in online mode.

2. Install MFCMAPI Tool
3. Go to “Tools” > “Options”.
4. Make sure that “Use the MDB_ONLINE flag when calling OpenMsgStore”
5. And “Use the MAPI_NO_CACHE flag when calling OpenEntry” are checked. Click “OK”.
6. Click on “Session” > “Logon”.
7. Choose the Outlook profile
8. Double click the profile
9. Expand “Root Container” > Scroll down > Expand “Top Information Store”.
10. Select Inbox
11. Locate PR_ADDITIONAL_REN_ENTRYIDS_EX attribute in Inbox folder
12. Copy the value in a txt file and save it in the machine.
13. Remove the value and change it for this value:


check if the issue persists.

So this worked for a few weeks? I will try this also and let you know.
Keep me posted ;)

@Roel80 Nice. That is different from what we were doing. We have been deleting the PR_ADDITIONAL_REN_ENTRYIDS_EX attribute and letting Outlook rebuild it. After some time, the issue re-appears.

Perhaps replacing it with that data will help. Fingers crossed!

Yes fingers crossed, untill now it works!