Update Rollup 8 for Exchange Server 2007 Service Pack 1 release announcement!

Published 05-19-2009 09:55 PM 3,374 Views

We have released Update Rollup 8 for Exchange Server 2007 Service Pack 1 (KB 968012) to the download center. The release of the rollup via Microsoft Update will happen on May 26.

As in the previous rollups, we have done a mix of product improvements (aka Critical Design Change Requests) and bug fixes. A few key ones which I would like to call out are as follows:

  1. KB 969690 - We have fixed the bug introduced in Update Rollup 7 which caused the sender of the Delivery Status Notification (DSN) to be unresolved.
  2. Disable kernel mode authentication in Windows Server 2008 for CAS servers - As documented here, it was required to manually take the additional step to configure the CAS servers running Windows Server 2008 to disable kernel mode authentication. Starting this rollup, the installer will configure this for you.
  3. X-Header promotion to named properties- Change to the way X-headers are promoted to named properties. More on this in Jason Nelson's blog post Named Properties, X-Headers, and You.
  4. KB 961606 - We have fixed a bug where Outlook Web Access (OWA) users may find that the font size of plain text messages is extremely small on third-party Web browsers.

KB 968012 has more details about this release and a complete list of all fixes included in this rollup.

As a follow up to the Exchange Server 2007 Service Pack 2 (SP2) announcement, all fixes in this Update rollup and the previous ones we have released for Exchange Server 2007 will be included with Exchange Server 2007 SP2. We will have a blog post soon which covers:

  • When update rollups can be expected for Exchange 2007 SP2.
  • Support plans for Exchange 2007 SP1 which will be in support as per the timeline in Microsoft's Service Pack Support Policy.

As always, the Exchange Software Updates forum is available to provide help if you encounter issues in the updates we release for Exchange. We have staffed the forums with engineers monitoring the forum ready to assist you and request you to utilize that mode instead of asking for help via comments on this blog.

- Exchange Customer Experience team

Not applicable
#8 Required a reboot on my Server - I don't recall the other Rollups requiring a reboot.
Not applicable
It is good to restart anyway after a rollup update :)
Not applicable
We do file in use detection in our update rollups. If the installer cannot stop a service or a user application (like Exchange Management console or Shell) is open and has a DLL loaded, a reboot will be required.
Not applicable
"New updates not only fix old bugs, but sometimes bring some new ones" :)

Русская версия этого поста (Russian mirror of this post) здесь: http://www.maximumexchange.ru/2009/05/20/exchange-2007-sp1-update-rollup-8/
Not applicable
I have heard that this new update causes the Exchange server to loose all services and not be able to start.
What comments can you provide regarding this rumor/fact?
Not applicable
Hi Zaphod - if you are hearing this, can you please refer to the source so that we may investigage? Also, please check in our software updates forum http://social.technet.microsoft.com/Forums/en-US/exchangesoftwareupdate/threads/ to find out if any issues have been listed.

Not applicable
I had to install this patch becuase the store.exe kept blowing up. I installed it, no reboot, all services came up fine and no more store.exe crashes!! Thanks Guys!
Not applicable
Why is it that the roll updates updates restarts the Forefront services when done, but not the Microsoft Exchange services (Anti-spam Update, Credential Service, Transport, Transport Log Search) on our Edge? I have seen with this and all previous roll updates. I always have to restart them manually or reboot the server.

On our internal server (which runs all other roles) #8 required a boot too, which never happened before, and which I frankly don't understand since it disables all services beforehand.
Not applicable
Reboot when all services are restarted can happen if any file is in use that the file cannot control; e.g., third party application, EMC, Exchange powershell, ...). This is often seen.

On the Edge case, I will get back to you on that. Can you post the issue in http://social.technet.microsoft.com/Forums/en-US/exchangesoftwareupdate/threads/ and cut+Paste the Servicescontrol.log from %SystemDrive%exchangesetuplogs.

Thanks - Scott MSFT
Not applicable
thanks for the very nice stuff. Its really a helpful article. Here i come to know about new announcement from Microsoft like Rollup 8 for Exchange Server 2007 Service Pack 1. Certain issues or busg will be fixed by this.

Thanks and regards
Not applicable
Definately seems like there's a problem with OutlookAnywhere.  So far I've tried every trick in the book I can find or think of.  A dialog has be started in the forum, but no luck so far.
Not applicable
UPDATE: it would seem that XP/OutlookAnywhere profiles do not like updating remotely, in my opinion.  On a hunch, I contected in through a VPN, opened up my non-working OA profile, password worked, everything updated, closed out, closed the VPN and reopened Outlook profile and no issue.  Creating new profiles remotely still seems problematic.  Vista machines, I no issues with old profiles or creating new ones.
Not applicable
It would seem that running:  "Set-OutlookProvider EXPR -CertPrincipalName none" clears up the issue I'm having with XP machines.  The command clears the msstd setting for Autodisover settings and I'm able to create Outlook 2007 profiles again on XP machines.  Oddly enough, never had an issue with Vista machines.
Not applicable
What is meant by "Any Interim Updates for Exchange Server 2007 must be uninstalled prior to installing this update rollup." in the requirements section of the download page?
We applied the updates per the WSUS prompts. Thank you
Not applicable
Carlos, the "Interim Updates" are temporary fix for issues that arosed within Exchange 2007 before the completed rollup update was released. Since you don't know about it, it is save to say you shouldn't worry about it, as you don't have any installed.
Not applicable
The rollup installation fails on a SMB 2008 server with Exch 2007 SP1
Not applicable

Can you post the issue in http://social.technet.microsoft.com/Forums/en-US/exchangesoftwareupdate/threads/ with details on the failure you see?
Not applicable
After applying exchange 2007 SP1 roll up 8 , the store.exe is jugging the memory @ 95% usage.. This is a pre-production servers with two users.

Memory usage was at 20% average for the past 5 months. This is CCR environment.
Not applicable
Not applicable
Ahh finally, a fix to those pesky DSN. Recommend reboot after every Rollup - that way you can see if anything breaks when a service is starting. : )
Not applicable
I have a question about preventing the latest rollup from being installed.

My current Exchange environment consists of seven servers, all with SP1 Rollup 7 installed.  I'm adding an eighth server, and want to install Rollup 7 to match the others, but the installer automatically tries to install Rollup 8.

Based on Microsoft's documentation, I'm supposed to update the internet facing servers first, then the others.  Well, the new server is not internet facing and should not have Rollup 8 installed before some others.  

How do I avoid having Rollup 8 automatically installed on my new server, and install only Rollup 7 for now?
Not applicable

Can you check the updates folder on your Exchange setup location t see if it has the MSP for Update rollup 8 ?

If this does not solve your issue post it in http://social.technet.microsoft.com/Forums/en-US/exchangesoftwareupdate/threads/ and we can troubleshoot.
Not applicable
Hi Guys,

it really fix all issues of exchange specially the Exchange Information Store service crashes..
Not applicable
win2008 sp1 server, exchange 2007 sp1 rollup 8.
full search index does not work at all, confirmed index was enabled on the store, used all ps comands to remove and re-create index, but it refuses to do a crawl, and the index folder sits at 129k in size.

Not applicable
My issue has been resolved.

When launching the Rollup 7 installation, it checks to see what Rollups are currently installed.  Rollup 8 was already installed because it was located in the 'updates' folder in the Exchange installation source files.  I did not see it in the Programs and Features window because I had not selected "View Installed Updates".  Once I selected this option, I could see that Rollup 7 and Rollup 8 were both automatically installed during the Exchange installation because the .msp files were located in the 'updates' folder.
Not applicable
Installing Rollup 8 broke OWA -- users get a blank logon screen in IE (ironically, other browsers still work).  I reinstalled 64-bit asp.net because I had a vague memory of that procedure fixing the same issue after installing an earlier rollup, but no change.  Anyone else have this problem?

Jim Shilliday
Not applicable
Rollup 8 broke OWA for us too.  No solution thus far.
Not applicable
We have upgraded Exchange 2007 SP1 RTM (no UR) to Update Rollup 8 without any problems on multiple SBS 2008 servers.

We had major problems with SBS 2008 and previous UR releases. This one though, is different. It seems to fix problems this time.

Note: we did a server reboot BEFORE installing UR8, after that, NO reboot was required, but we did a reboot AFTER UR8 install anyway. OWA running fine.
Not applicable
After Loading my custom OWA Theme, OWA has stopped working and I get a blank page..  I've restored the backups of the files however the issue still exists..  good times
Not applicable
After installinr UR8 we had the following error sin the eventlog. Has anybody the same message or a solutionfor that?

The store driver couldn't deliver the public folder replication message "Folder Content (PUB1-SG1-xxx@xxx)" because the following error occurred: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)
Diagnostic context:
   Lid: 10648   dwParam: 0x6D9      Msg: EEInfo: Generating component: 2
   Lid: 14744   dwParam: 0x6D9      Msg: EEInfo: Status: 1753
   Lid: 9624    dwParam: 0x6D9      Msg: EEInfo: Detection location: 501
   Lid: 13720   dwParam: 0x6D9      Msg: EEInfo: Flags: 0
   Lid: 11672   dwParam: 0x6D9      Msg: EEInfo: NumberOfParameters: 4
   Lid: 8856    dwParam: 0x6D9      Msg: EEInfo: prm[0]: Unicode string: ncacn_ip_tcp
   Lid: 8856    dwParam: 0x6D9      Msg: EEInfo: prm[1]: Unicode string: server1.domain.local
   Lid: 12952   dwParam: 0x6D9      Msg: EEInfo: prm[2]: Long val: -1527653632
   Lid: 15000   dwParam: 0x6D9      Msg: EEInfo: prm[3]: Pointer val: 0x000000001A1A1760
   Lid: 19778  
   Lid: 27970   StoreEc: 0x80040115
   Lid: 17730  
   Lid: 25922   StoreEc: 0x80040115.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Not applicable

Installed to our internal owa server... to find that owa is not working anymore. Blank page.. Exact same symptoms as with RU2

"When you install Update Rollup 2 for Exchange 2007, you experience the following symptoms:

After the installation of Update Rollup 2 for Exchange 2007 is complete, users cannot log on to Outlook Web Access. In this scenario, the users are redirected to a blank Web page that has a URL that resembles the following:



but no fix yet...  :(

Funny thing is that our external owa page which is accessed through isa to a different server is working fine even after the upgrade.

Not applicable
Rollup 8 Broke OWA for us as well.  Uninstalling it fixed OWA.  It did the same thing that others mentioned here: No graphics and what looks to be just the text of OWA when browsing it.
Not applicable
I don't have problems with OWA, works normally, we use both form-based authentication (higher security for external use/webmail) AND Integrated authentication (for internal use, sharepoint integration).
But it might be that we have a problem with delegates accepting meeting requests. After rollup package 8 it seems that an appointment, will stay tentative after the delegate accepted the meeting request e-mail. When you open the user mailbox calendar and view the details of the appointment, you can see that the delegate accepted but it remains tentative, also after some time of waiting (> 2 hours, no change).
The delegate is has publishing editor permissions on the Calendar.....
Does anybody also have noticed this behavior? The user has an iPhone which he uses to synchronize with exchange...(read something about problems with blackberry devices and delegates accepting problems...)
Not applicable
When I installed Rollup 8 my OWA broke. When you went to the OWA URL you would get a blank page. After spending a few hours on this and seeing similar scenarios for other Exchange rollups when googling for blank page, I unistalled RU 8 and the issue went away.
Not applicable
Rollup 8 broke OWA for me too, same as previous poster where the graphics were missing and couldn't click on anything. Uninstalled it, and problem went away.  Manually downloaded the rollup and reinstalled. Rebooted server and all Exchange and IIS services were set to "disabled".  Had to reset them to "Automatic" and start them.  Looks ok now, but I'm uncomfortable not knowing why all the services were disabled.
Not applicable
I just applied the Rollup 8 and it broke OWA.

I found the following article that fixes it:

Hope it helps!
Not applicable
Hey guys, is it that difficult? Every single RU so far failed restarting the services on servers hosting HT only (with ForeFront 10.1.0809 installed). Error: "'FSEIMC' failed to start". It's not a problem with that service since setup doesn't even try starting it (so it looks like you forgot again that there's a dependency). Why is nobody testing at least the Microsoft products? Especially when this issue occured ever since RU1?

Not applicable
Is there any specific order in which the RU8 needs to be installed? In other words, should it be installed on the CAS first then HUB and finally MBX?
What about staggering the installation over a period of a few days? Is there any documentation on this?

Not applicable
We have CAS/HT roles co-existing on the same servers. Rollup 8 broke our ability to create new *functional* receive connectors. Fortunately, the existing ones were still there and working, but modifying any existing, or creating new ones stopped working. Sure they showed in the list, but beyond that, they didn't work. I uninstalled rollup 8 and they started working again.

I haven't seen this particular scenario documented anywhere, and our environment isn't anything beyond the norm.
Not applicable
Rollup 8 installed without any problems on my stand alone
windows 2008 x64 server.

Rebooted after install, OWA, and everything else is working

Thanks Guys  Paul.
Version history
Last update:
‎Jul 01 2019 03:44 PM
Updated by: