Update Rollup 4 for Exchange Server 2007 SP1 has been released

Published Oct 07 2008 06:58 PM 3,356 Views

EDIT 10/9/2008: We updated the MU (Microsoft Update) release date of this patch as well as the Installation Notes section.

We have released the final version of Update Rollup 4 for Exchange Server 2007 SP1 (KB952580)

The update is live at:

Related KB article:

The rollup is marked as "v2" in the file name i.e. "Exchange2007-KB952580-v2-x64-EN.msp" to account for the accidental release of v1 via Microsoft Update on 9th September. This version of rollup will install over the "v1" mentioned above if you have installed a v1 when it was accidentally released.

The rollup is available via the download center link starting today. It will be available via Microsoft Update starting with 11/4/2008.

Installation notes

There are a few possible installation issues that we would like you to be aware of:

  • Exchange 2007 managed services might time out during certificate revocation checks
  • When installing a Rollup, we recommend you use the same account that you used to install Exchange Server. If you are using a different account, that account needs to have Local Administrator rights as well as rights to read Active Directory on Exchange object as well as server level (as the update needs to determine which roles are installed on the server). Not having required permissions can lead to OWA not being updated correctly and displaying a blank page after update has completed.
  • If you have modified the logon.aspx file, it will not be patched by the Update Rollup installer. As a result Outlook Web Access may not be updated correctly and it may display a blank page after the update has finished. In order to avoid this problem, rename the logon.aspx file before applying the update rollup. After you apply an update rollup package, you must re-create Outlook Web Access customization in logon.aspx.
  • The update might take long time to apply. To try preventing this, follow the instructions in this post before applying the update. We are working on a permanent fix for this.

- Nino Bilic

Not applicable
Where's the fix for OAB generation on Server 2008 clusters?  What about the fix for the diversion header bug in which there's an intermediate patch out.  Why isn't this included?
Not applicable
I don't see the fix for Entourage crashing the OWA Application Pool in exprox.dll when it sends message over 50 KB or so. Is this included or scheduled for a later UR?
Not applicable
Not a biggie, but a potentially confusing typo in the KB article. The page it links to correctly says UR4 instead of UR5.

954058 (http://support.microsoft.com/kb/954058/) You can change the method for transfer encoding after you apply Update Rollup 5 for Exchange Server 2007 Service Pack 1
Not applicable
The OAB share issue with a Win2008 CCR doesn't seems to be fixed yet ! This is yet another counter-argument for CCR for companies intending to deploy E2K7 over Win2008 and don't want to plan a dedicated MBX role for this usage ! :p
Not applicable
On my server the "Computing Space Requirements" step took an unusually long time (approx 4 minutes) -  many people may assume it is an AppHang - any ideas why?
Not applicable
On my server the last bit of installation (Creation of native image for .NET) is still in progress after 30 mins. I can read that it would take an extended period of time to complete. Can anybody tell me how long he has waited before having the installation complete ?
Not applicable
"Computing Space Requirements" is the MSI itself figuring out things. We just now disabled the 'next' button based on customer feedback. it used to pop-up another dialogue box saying for you 'to wait until it finishes' that caused additional confusion.

This is the NGEN issue where NGEN /update is called using a priority of 3. There is a fix in the works for the patch to do a better job. I cannot communicate the exact ETA on that.

FYI - It will finish eventually. Not a great answer but one that I can quickly write out on this blog.

Benoit + Michael,
These changes look good for being in RU5. I can't promise that it will be there when RU5 ships though. It just is looking good.

We are cleanig up the kb. Thanks!

I am not tracking this particular rollup to released on MU. Please download and install it from the download center. Rollup 5 will be released on MU.
Not applicable
I am dealing with this Entourage issue crashing OWA as well, is there a hotfix for this issue?
Not applicable
We had RU 3 installed (manually) on our Win2k8 server and put RU 4 on last night (also manually after uninstalling RU 3). This morning, our WSUS server (v3.1) installed RU 2 (which had been approved back in June) onto our server. WSUS didn't seem to detect that RU 4 was installed and went ahead with installing RU 2 - it detected RU 3 happily - is there a flag or something missing in RU 4 that WSUS isn't seeing?

Not applicable
Scott - thanks for the update!

SteveT - I had heard there was an interim fix/workaround, but I never contacted PSS to see if this was so. I might do so in the next week or two after I install UR4.
Not applicable
On my server the last bit of installation (Creation of native image for .NET) is still in progress after 120 mins and still not completed...
Not applicable
Alstair -
I Applied Update Rollup 4 on m test servers and WSUS does not push RU 2 and 3. WSUS reports my test exchange servers are up to date.

On my test system, the whole update process took no more than 15 minutes.
I applied this NGEN fix(http://msexchangeteam.com/archive/2008/08/01/449426.aspx)
It might improved upgrade experience(?)

And on KB952580

954058 (http://support.microsoft.com/kb/954058/) You can change the method for transfer encoding after you apply Update Rollup 5 for Exchange Server 2007 Service Pack 1 ----Rollup 5 for ex2k7 sp1???
Not applicable
We are also having the problem seem with Entourage crashing OWA, and we're dying for a fix!  

A support ticket has done nothing as yet except to confirm there might be a bug.
Not applicable
I installed this on our Exchange Cluster and now the databases won't failover.  Any ideas?  I am having flashbacks to Rollup Update 3 for SP1 where we didn't even install after the hassle we had on the first server.
Not applicable
I installed the RU4 on a Exchange 2007 SP1. When I run Windows Updates it shows RU3 as required update.Aren't the RU cumulative ?
Not applicable
I don't know what to say as I have tried this update 2 times and each time I download the French version and check the registry it shows v1.

What gives?

The downloaded file is indeed marked as "-v2-" but its not!

I'm impressed...thanks.

Not applicable
I Installed a new Exchange 2007 SP1 on W2K8 Std today and when I install this UR 4, I am unable to access OWA. I got the following error:




User host address:


Exception type: Microsoft.Exchange.Clients.Owa.Core.OwaInvalidConfigurationException

Exception message: Object reference not set to an instance of an object.

Call stack



Microsoft.Exchange.Clients.Owa.Core.Global.ExecuteApplicationStart(Object sender, EventArgs e)

Inner Exception

Exception type: System.NullReferenceException

Exception message: Object reference not set to an instance of an object.

Call stack

Microsoft.Exchange.Clients.Owa.Core.Configuration.CheckAllLegacyPublicFolders(ADSystemConfigurationSession session, ADObjectId[] pfdbIds)

Microsoft.Exchange.Clients.Owa.Core.Configuration..ctor(ADSystemConfigurationSession session, String virtualDirectory, String webSiteName, ADObjectId distinguishedName, Boolean isPhoneticSupportEnabled)



I did configure certificates and internal URL for OWA, didn't do any other configuration tasks. So if anyone has an idea to fix this please let me know.

P.S when I uninstall UR4 all problems are gone, so this "has" to be related.

Not applicable
I have installed the RU4 on a Exchange 2007 SP1. When I run Windows Updates it shows RU3 as required update??? I thought that windows update needed some time to update its database or something???
Not applicable
Rollup 4 will be released on or about 11/04 via Microsoft Update. At that time, I will put in a fix to the Microsoft Update detection logic that will handle the scenario where a previous rollup is offered by MU/WSUS. This will address this scenario moving forward.

Not applicable
So, the instructions say to remove any "interim" updates before installing rollup 4. Does this include RU3 or RU2? I have not uninstalled RU2 before I did RU3.

Anyway, it would be nice if the KB would clarify this point as I'm sure I'm not the only one who might wonder about this.

Not applicable
Hi Scott,

Any chance you can clarify the issue with the French version I've got?

i.e. that the downloaded file is marked as version 2 ("...-v2-...") but looking in the reg after installation its clearly marked as version 1.

Not applicable
I installed RU4 on W2k8 E2k7.  OWA, ActiveSync, OAB stopped working.  3 hours later I'm still stuck.  I have yet to have an uneventful patch of E2k7.  Wish i stayed on E2k3 :(
Not applicable
I have trouble with OWA after the rollup has been installed.  It works fine when I connect directly to the server but if I connect via ISA 2006 I get a message "Error Code 64: Host not available".  When I rollback the patch everything works fine.  Any ideas?
Not applicable
Update on my comment above.  Got OWA
working by turning off SSL required.  The
issue may not be RU4 but something in the
other few security patches Installed at the
same time.  I'll investigate further.

Also, ActiveSync is working on mobiles again if you
you use the FQDN rather than just the DN on
the moble setup parms. Again, seems to be
some sort of tightening up that breaks things
if you were sloppy

Still can't figure out why OAB and AutoDiscovr
stopped working.   Anyone have any ideas?
Not applicable
Rollup 4 somehow messed up the 443 bindings for the
default website.  That in turn shutdown SSL and
led to bad things for most of exchanges web based
communication.  I deleted the binding in IIS and simply readded it again using the same certificate.  All problems solved.

Whether this is a hard repeatable bug in RU4, or, something setup by pre-existing circumstances, I can not say.  Interesting to see if this has happened to anyone else.
Not applicable
OK, Installed Rollup 4. The Server Team run Windows Updates and installed Rollup 3 because it showed as needed.
What should I do now ? Reinstall RO4 ?
MS should be more responsible on Patch Deployments!!
Not applicable
For those of you having issues with the install "hanging", when I applied RU3, each server had to have internet access for some reason which was not mentioned in the requirements for install in the kb article. Not sure if it is the same with RU4 as I am just starting to look at it.

Andrew G: Did you fix your issue with OWA not working with ISA 2006? Are you running ISA with recently released SP1?

Dave Dunn: Did you apply this to your cluster environment? Any issues? What type of clustering are you using?
Not applicable
I can confirm the entourage bug is still present. We are still at rollup 2 becasue of it.
Not applicable
Installed this patch on our 2 exchange boxes last night and this has brought both servers down. Services have been set to disabled.
In the process on uninstalling. Going back to Rollup 3
Not applicable
What do I do if I didn't rename the logon.aspx file?  OWA is broken because of that.
Not applicable
Argh. Evil to us as well. None of the things that have helped some folk have helped us. We just have to roll back (that works).
Not applicable
Ok so I did not have a custom logon.aspx file.  I ran the rollup today as part of Windows update and after the reboot, I got a blank OWA page using IE, and in Safari and FF3 I got a white screen with text, and some boxes, total mess.

So I downloaded the rollup again from here.


Applied it over the top and it fixed it.  No reboot required BTW.  Thought I was going to have a looooooooong weekend:(

Not applicable
I installed rollup 4 on thursday Nov 6,
my server (08) is hosed, uninstalled the pathch
server is still hosed, services will not start
Not applicable
I'm with matty abouve, I installed RU4 on a test machine and when done all services said disabled and after rebooting services would not start?? Any Help besides uninstalling?
Not applicable
For everyone saying their services are disabled:

What this is telling us is that the setup of RU4 actually failed (did not complete successfully). Because of that - I would suggest (to those that experienced this problem) to open support cases so this can be looked into. This is definitely not expected and we have not seen a big influx of support cases with this symptom...
Not applicable
I have on several servers noticed that if I put Rollup 4 in the update directory before the installation it stops during the installation of HUB.
Not applicable
Also here services down, but everything went fine when i put rollup to computer which have all roles itself.
Not applicable
We installed it last night on our only server running all roles other than UM and Edge and the only fault we had was with OWA.  We found that the ClientAccessOWA8.1.311.2 folder did not have anything in it other than folders so I copied the contents from the folder
Not applicable
I called Microsoft support and the following was the fix that worked for me when after installing Rollup 4 the services did not start. It seems to have something to do with getting access to a Microsoft crl URL... But anyway this registry fix seemed to have done the trick for me anyhow.

1.In Registry Editor, locate, and then right-click the following registry
2. Point to New, and then click DWORD Value. In the right pane of Registry
notice that New Value #1 (the name of a new registry entry) is selected for
3. Type ServicesPipeTimeout to replace New Value #1, and then press ENTER.
4. Right-click the ServicesPipeTimeout registry entry that you created in step
and then click Modify. The Edit DWORD Value dialog box appears.
5. In the Value data text box, enter the desired timeout value in milliseconds
click OK. For example, if the new service timeout should be 60 seconds (60000
milliseconds), then enter 60000.

I changed mine to 120000 and it's working ok..
Not applicable
Same for me services are no longer starting, installation take 3:30.
Is uninstalling the rollup is safe or is it better to restore from backup ?
Role is HUB/CAS
Not applicable
Adding the registry key is working fine, can I keep this in production without problem?
Not applicable
I've decided not to install any of the rollups microsoft release for exchange server 2007. I installed rollup 3, it screwed up my OWA. I installed rollup 4(it took an average 3 hours to complete), it brought down my CCR cluster along with HUB and CA. Services do not start, my cluster wont move, mailflow stopped. What a disappointing fact. I spent almost 4 months planning and setting up that CCR. Now its juts useless. I read the entire release notes  but did not find anything like this mentioned in it. now I see i'm not the only one with the same issues. where do you guys test the rollups? My setup was brand new. everything setup as per MS best practices. Windows 2008, exchange 2007 sp1, OS updated, how could this happen? the only additional software in these servers were McAfee AV. Very Very disappointing.
Not applicable
I tried installing the RU4 on my backup (resource forest) server. same issue. services wont start.
Not applicable
RU4 install went fine on my 4 exchange servers.  2 CAS/HUB and 2 MAIL/HUB.  Just in case, I did turn off the mcafee groupshield services on the mailbox servers while the update ran.
Took about 10 minutes to run on each server.
Running Windows Server 2008 SP1 and was previously at Exchange 2007 SP1 RU3.
No complications.  Just had to rename/delete my customized logon.aspx so I got the new file and then had to make the customizations with the new file.

Glad to see other people are having the OWA exprox crash (so maybe it will get their attention).  They better fix this soon......

Good luck all!
Not applicable
Hi, in fact the problem come if your server do not have acces to internet. if you just open internet acces for exchange server to the site crl.microsoft.com the problem will be solved. And i'm not sure but I think do it one time, use all services and tools one time and cut the acces, it will still works ;o)
have fun ...
Not applicable
we were working after ru1 without any problems.  Microsoft update installed 3 and when the server restarted none of the services could be started--resolved by removing 3 and going back to ru1. Same happened with ru4. Not sure why--any suggestions
Not applicable
Just a point to ponder... For whatever reason all of our servers have internet access and when I try to access the below URL
http://crl.microsoft.com/pki/crl/products/CSPCA.crl it comes up with File association issues?? The URL works on all of the desktop machines that I try but for whatever reason it fails to associate on our server OS's. The registry fix works but it would be nice to know why this happened in the first place? Microsoft Support says something is being blocked but after checking nothing is blocked.

I do not think RU4 will work for alot of folks even with internet access because of this File association issue. I'm still banging at it to try to figure it out and will update this blog once I do.
Not applicable
Fresh install; update rollup 4 from MS update still broken ....
Version history
Last update:
‎Oct 07 2008 06:58 PM
Updated by: