Resolving MMC 3.0 errors when installing Exchange 12 CTP release

Published 03-23-2006 10:41 AM 1,506 Views

As mentioned before - we now have CTP build of Exchange 12 those of you that have MSDN and TechNet subscriptions can install it.


One issue that seems to come up frequently for those of you that have tried installing this build is the following error at Setup:


"Exchange Server '12' requires Microsoft Management Console 3.0."


This happens even though the final (RTM), released version of MMC is installed on the system.


The problem here is that the CTP build of Exchange 12 setup actually needs a "RC1 refresh" build of MMC 3.0, and as this build is not found - the setup fails with the above error. E12 is looking for a registry key that is not there on the machine that has RTM version of MMC 3.0 installed. This issue is going to be fixed in later builds of Exchange 12 and will definitely not be there in final release version.


You can resolve this problem in 2 different ways:


1.    Download and install the RC1 refresh MMC release, see Microsoft Management Console 3.0 Pre-Release (RC1 Refresh).  


2.    If you would like to run the RTM version instead (as you already installed it) create the following empty registry key:




- Nino Bilic

Not applicable

Pokud jste predplatitele MSDN/Technet a snazite se nainstalovat CTP verzi Exchange12, mohli jste narazit...
Not applicable
Someone using a modem on a dirty phone line or something?  Wow... I haven't seen gibberish like that in years.
Not applicable
Seems like there's something missing in the Regkey:

guess it's gone be "windows"?
like in:

Not applicable
Thank you Oliver - fixed!!
Not applicable
Blimey "Holy Cow", I hope you're being ironic there; if you said that stuff about Gaelic I'd have to kick your head. ;)
Not applicable
Not applicable
Not applicable
I was thrilled to finally get a new “server” set up and running at home so I could install...
Not applicable
Today this list is longer, since I hadn't the time to post it last week. Sorry...

Exchange on NAS:...
Not applicable
I'm staying in a hotel in London all this week delivering part of the Exchange 12 ignite roadshow.  ...
Not applicable
Microsoft’s Exchange 12 Beta arrived in my TechNet pack, and I had a box on which to install it. Why not? The Beta supports 32-bit hardware; production versions will not, according to the release notes. Installation was only a minor...
Not applicable

Ok It works on this point.

But at the begining of the "progress" part it stops with an error 1602 "installation stoped by user" (d:servereni386exchangeserver.msi)

I'am installaing on Windows server 2003 enterprise edition R2 (french). The system is clean, this computer is DC and I chose all roles except "gateway server" the 5 pre-checks were ok.

Anybody can help

Not applicable
I still can't get this working.

Firstly, I added the registry key. I got the same error message.

Secondly, I installed Microsoft Management Console 3.0 Pre-Release (RC1 Refresh). I got the same error message.

Any help ???

Version history
Last update:
‎Jul 01 2019 03:12 PM
Updated by: