Released: Update Rollup 1 for Exchange Server 2010 SP1

Published Oct 07 2010 01:20 PM 10.8K Views

Earlier today the Exchange CXP team released Update Rollup 1 for Exchange Server 2010 SP1 to the Download Center. The release of the rollup via Microsoft Update will happen on October 12th.

This update includes new fixes for the following server roles:

  • Client Access
  • Mailbox
  • Edge Server
  • Hub Transport

In particular we would like to call out the following fixes which have been included in this release:

  • 2028967 Event ID 3022 is logged and you still cannot replicate a public folder from one Exchange Server 2010 server to another
  • 2251610 The email address of a user is updated unexpectedly after you run the Update-Recipient cmdlet on an Exchange Server 2010 server
  • 978292 An IMAP4 client cannot send an email message that has a large attachment in a mixed Exchange Server 2010 and Exchange Server 2003 environment

Note: The above links may not be live at the time of this posting.

Rollup 2 for Exchange Server 2010 Service Pack 1 is currently scheduled to release in early December.

Note for Exchange 2010 Customers using the Arabic and Hebrew language version

We introduced two new languages with the release of Service Pack 1, Arabic and Hebrew. At present we are working through the process of modifying our installers to incorporate these two languages. Due to the timing of RU1 we were unable to complete this work in time.

Customers running either of the two language versions affected are advised to download and install the English language version of the rollup which contains all of the same fixes.

Note for Forefront users

For those of you running Forefront, be sure you perform these important steps from the command line in the Forefront directory before and after this rollup's installation process. Without these steps, Exchange services for Information Store and Transport will not start back up. You will need to disable ForeFront via fscutility /disable before installing the patch and then re-enable after the patch by running fscutility /enable to start it up again post installation.

Kevin Bellinger

Not applicable
Wow, that was quick :)  Glad you guys are working on fixing some of the issues introduced in SP1.
Not applicable
Great work guys
Not applicable
on the download page (

there is a link to KB982639.  Shouldn't that be a link to KB2407028 instead?

Not applicable
so if I am running the English version of Exchange and using Arabic OWA, Can I apply RU1 Safely.
Not applicable
The download page's KB links to (Ru4 for Ex2010)
Not applicable
Good job people!
Not applicable
After the install, OWA failed to be accessible, event log states that no all necessary files are in the owa14.1.255.0 directory.
Not applicable
@Mahmoud Magdy: Yes.
@Chris: Thanks for catching that - we'll update it!
Not applicable
After applying the Rollup I noticed the Version is still at 14.1 (Build 218.15). How can I tell which server has had the Rollup 1 applied?
Not applicable
@Ken: EMC or EMS (get-ExchangeServer | fl Name,AdminDisplayVersion) doesn't reflect the rollup version. There are several places to look, but all of them are at a local level (Add/Remove Programs, registry). You can also use a script like this one I wrote:
Not applicable
@Bharet: The download page still mentions "Knowledge Base (KB) Articles:KB982639 " in the Quick Details section.
Not applicable
Tried to installed the rollup but got an access denied error during installation. Does this update require debug privilege
Not applicable
@ jbourdet:
Try opening an elevated prompt and launching the .msp from the cmd line.
This has been usual behaviour for Exchange Rollups since a few.
Not applicable
There seems to be a problem with the way the patch stops and starts services... I've posted details on the Exchange Software Updates forum (post:
Not applicable
Hello guys,

after update to UR1 I now have problems with my management console. I installed the console on my windows 7 client. No connect possible. Before update I could connect. It seems that there ist a conflict with the version installed on my client and ther version of Exchange on my Server.
Installing RU1 on my client won't work. It's always rolling back.
Any ideas?

Greets Olli
Not applicable
I had the same issue. Start an administrator command prompt on the Windows 7 client and start the msp-file from there. The UR1 setup then should run fine. I was able to connect to the Exchange 2010 servers afterwards. I hope Billy gets little electrical shocks everytime when things like this happen...:-)
Not applicable
Hello ThomasG,

thanks for your reply. It worked!!!! I should have known it from the RU updates before. There I had to install the updates as administrator, too.

Kind regards

Not applicable
It appears that RU1 for Exchange 2010 SP1 doesn't fix OWA redirect issue introduced with SP1.
Not applicable
The redirect issue  you mention apparently is by design - SP1 enables SSL Required on Default Web Site. Simply uncheck "SSL Required" for Default Web Site, and redirect should work as before.
Not applicable
Thanks for this interesting information. Really helpful
Not applicable
I ran the update last night and after the restart one of my DB's couldn't mount.
Active Manager failed to mount database Sales on server Mail.Domain.local. Error: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetDatabaseCorruption: Unable to mount database. (hr=0x80004005, ec=-1206)

Subsequent resolution efforts have failed so have to restore the whole DB from backup, still running now so fingers crossed.
Not applicable

I'm having this problem
After the install, OWA failed to be accessible, event log states that no all necessary files are in the owa14.1.255.0 directory
Not applicable
This is the error
Outlook Web App failed to load the following theme folder: F:Program FilesMicrosoftExchange ServerV14ClientAccessowa14.1.255.0themesarctc

The following files are missing: premium.css, gradienth.png, gradientv.png, csssprites.css, csssprites.png, csssprites2.css, csssprites2.png

Also, I was missing the files posted on:
4 The Missing Exchange Management Shell Shortcut
I have copy all of them to the bin directory and deinstall and install again the Rollup1..

Same problem
Maybe is a problem because the SP1 setup was not correct?

How can I fix it?

Not applicable
Hi Again,
on the UpdateCas.log
I'm getting
17:04:24] Updating ECP to version 14.0.702.0
[17:04:24] Copying files from 'F:Program FilesMicrosoftExchange ServerV14ClientAccessecpCurrent' to 'F:Program FilesMicrosoftExchange ServerV14ClientAccessecp14.0.702.0'
[17:04:24] Update ECP done.
[19:33:27] ***********************************************
[19:33:27] * UpdateCas.ps1: 14/10/2010 19:33:27
[19:33:27] Error updating OWA/ECP: The term 'Get-ExchangeServer' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
[22:27:19] ***********************************************

The strange thing is that if I run 'Get-ExchangeServer'  on the PShell I don't get an error..

Not applicable
I'm logged in as the domain admin which I've verified is in the Exchange Organization Administrators group as well as I'm running the .msp file from an elevated command prompt (as suggested in previous comments). However, even after this the installer fails with the following message:

The user who's currently logged on doesn't have sufficient permissions to install this package. You need at least exchange server administrator permissions on the current computer to complete this task.

How can I "fix" this?

Not applicable

This was fast. Just a quick question for the Exchange Team:

Does the Update Rollup 1 fix the issue with search folders when moving mailboxes from Exchange 2003 to Exchange 2010 SP1?

I' moving mailboxes from Exchange 2003 to  2010 SP1, and a lot of mailboxes
can not be moved, i get the following error:

The Microsoft Exchange Mailbox Replication service was unable to apply search criteria to a search folder.
Error: MapiExceptionInvalidEntryId: Unable to SetSearchCriteria. (hr=0x80040107, ec=-2147221241)
Not applicable
This was installed for me via Automatic Updates, and completely broke my OWA. Previously, it was stock with SP1 and Forefront. It created the ClientAccessOwa14.1.255 structure with all the right subfolders, but ALL the folders were blank, except for one file: scriptspremiumuglobal.js. Obviously, this threw errors of  Microsoft.Exchange.Clients.Owa.Core.OwaThemeManagerInitializationException "Couldn't find a 'base' theme". Attempting to copy over the files from the base SP1 OWA14.1.218.13 folder got me nowhere, and so i've had to resort to removing the patch. Nothing else is installed on the system/ any major modification to the stock exchange setup, so this strikes me as pretty, pretty odd. Any chance someone could have a look over this?
Not applicable
I'm running Exchange 2010 Standard SP1 on Windows Server 2008 R2.  Installed the Update Rollup 1 last night and broke OWA; same issue as in the other commends, the themes were gone.  Tried tinkering to no avail, so removed the update, removed and re-added OWA virtual directory and now it's working again.
Not applicable
OWA redirection issue with Exchange 2007-2010 coexistence
& TMG fails with the following error:
"A temporary change has occurred that requires you to connect to a different server. To connect, click the button below.  For security reasons, you'll be asked to enter your user name and password again."

== Has this been taken care by this RU1 update.
Not applicable
Hello all the users with not running OWA.  Start an exchange powershell shell and run

C:Program FilesMicrosoftExchange ServerV14BinUpdateCas.ps1  

again. it helped at my system
Not applicable
Thanks Frank, that fixed my OWA!
Not applicable
I'm getting the following error:

"The user who's currently logged on doesn't have sufficient permissions to install this package. You need at least Exchange Server Administrator permissions on the current computer to complete this task."

This is puzzling because I'm logged in as the domain admin which should have all the rights it needs. It's the same account I used to install Exchange as well as SP1.
Not applicable
Anyone have an idea what the following error is all about, started popping up every hour or so after SP1 was installed.

Watson report about to be sent for process id: 7176, with parameters: E12, c-RTL-AMD64, 14.01.0218.015, M.E.RpcClientAccess.Service, M.E.RpcClientAccess.Handler, M.E.R.H.RopHandler.Logon, System.InvalidOperationException, 41bd, 14.01.0218.012.
ErrorReportingEnabled: False
Not applicable
Thanks Frank, your suggestion fixed my owa problem as well.  Of course I did need to do a reboot afterward for it all to work.
Not applicable
Frank Carius's solution worked like a charm.
Thank you very much for posting.
Not applicable
wow, reading about all these issues sound scary. Any reason that I should put off SP1 and even rollup 1? I cannot believe RU2 is coming out already. When will it be safe to update?

Should I update all servers with SP1 first then go back and do RU1, or update CAS to SP1, then do RU1 on it and move onto HUBs?
Not applicable
To fix the error with owa just copy all the files out of
C:Program FilesMicrosoftExchange ServerV14ClientAccessOwa14.1.218.13
C:Program FilesMicrosoftExchange ServerV14ClientAccessOwa14.1.255.0

and ignore the one and only file that there is a duplicate..

then restart IIS.
Not applicable
After applied rollup 1 for sp1  and the updates recommended for W2k8 R2 on a single server and now i can´t use owa on new or moved mailboxes. Owa just stuck after login credentials.
And If I use a old mailbox I get an error try to send mail.
I have tried all the things above but it didn´t help.
I Know I had a similar error before with Ex2010 sp1 Rollup 1 and hade to reinstall the cas server role. That solved it.
Not applicable
Thanks Matt....

I was running SP1 with everything working, but after Rollup 1 OWA stopped working.

Copying the library worked for me after IISRESET /NOFORCE
Not applicable
Hi, we have an issue with the Unified Messaging Language packs. Our default language for the dial plan is set to English UK but the users language in Web App is set to English ZA. Per the Technet Library doc:

"The default language is important to callers. When an Outlook Voice Access user calls in to the Unified Messaging system, the language setting chosen is based on the language setting configured in Outlook Web App that was set when the user first signed in to the mailbox using Outlook Web App. Unified Messaging then compares the language set in Outlook Web App to the list of available languages on the dial plan with which the user is associated. If there is no suitable match for the language, the default UM dial plan language will be used."

So we would expect English UK to be used but English US is used instead. Is this a bug or is our config not correct?

Not applicable
Who's upgrade  Sp1 & rollup 1 for exchange 2010 successful and no error . pls advice me . thanks
Not applicable
I've updrade Sp1 & RU1 for Exchange 2010 without any lab environment, suddenly the New Mailbox button doesn't exist any more in the ECP, there is any another custom console to get this feature enabled for help desk agent???
Not applicable

I've had no issues regarding installing the rollup 1 for Exchange Server 2010 SP1. All my customers running Exchange 2010 succesfully installed the update.

BR - Frank
Not applicable

I am also getting the error :

Watson report about to be sent for process id: 7500, with parameters: E12, c-RTL-AMD64, 14.01.0218.015, M.E.RpcClientAccess.Service, M.E.RpcClientAccess.Handler, M.E.R.H.RopHandler.Logon, System.InvalidOperationException, 41bd, 14.01.0218.012.
ErrorReportingEnabled: False

every 50 min or so.  anyone has an idea why and how to fix it. ?


Not applicable
For those having issues with OWA after Rollup installation:

FAQ 000072 - OWA does not work after Exchange Server 2010 update rollup installation

I regulary see this issue with Exchange 2010 rollup updates if you run it without elevated priviledges on Windows 2008 R2.

If you don't use Run As Administrator option it will complete without any error messages but due to lack of priviledges the setup will regulary break OWA in the background.

The solution that worked for me in most cases is simply to re-run the update with Run As Administrator.


It might be smart to adapt the install procedure to checks beforehand if user running the update has sufficient priviledges. This seems to be causing pain to a lot of people as I have 3000 + hits on that article.


Dejan Foro

Exchange MVP

Not applicable
Does Microsoft ever test anything before releasing it? What a joke.
Not applicable
I installed this through MS Updates and it screwed up my OWA. I then downloaded and ran the update over again by itself this time and it looks like my OWA is working again... so far at least.
Not applicable
Can you please make a response for the big problem with the mapiexceptionInvalidEntryid unable to setsearchcriteria please, we have this bug and i see lot of people have the same bug.

Not applicable
i can confirm that the error mentioned above,

Watson report about to be sent for process id: 7500, with parameters: E12, c-RTL-AMD64, 14.01.0218.015, M.E.RpcClientAccess.Service, M.E.RpcClientAccess.Handler, M.E.R.H.RopHandler.Logon, System.InvalidOperationException, 41bd, 14.01.0218.012.
ErrorReportingEnabled: False

is resolved once public folders are created.  It has to do with the BES 5.02 version, that must have public folders.
Not applicable
When will the patch be released that will allow Outlook2007 to view Exchange 2010 personal archives?
Version history
Last update:
‎Jul 01 2019 03:54 PM
Updated by: