Zählen wenn eine oder mehrere Bezeichnungen möglich sind

%3CLINGO-SUB%20id%3D%22lingo-sub-3028707%22%20slang%3D%22de-DE%22%3ECount%20if%20one%20or%20more%20names%20are%20possible%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3028707%22%20slang%3D%22de-DE%22%3E%3CP%3EHello%20everyone%3C%2FP%3E%3CP%3EI%20want%20to%20count%20from%20a%20column%20with%20different%20text%20entries%20in%20the%20cells%20those%20that%20I%20think%20are%20necessary.%20e.B.%3C%2FP%3E%3CTABLE%20width%3D%22225%22%3E%3CTBODY%3E%3CTR%3E%3CTD%20width%3D%22145%22%3ENo%20findings%3C%2FTD%3E%3CTD%20width%3D%2280%22%3E0%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3ERivet%3C%2FTD%3E%3CTD%3E%26nbsp%3B%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3E0.%20Unendorsed%3C%2FTD%3E%3CTD%3E%26nbsp%3B%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3EX.%20not%20available%3C%2FTD%3E%3CTD%3E%26nbsp%3B%3C%2FTD%3E%3C%2FTR%3E%3C%2FTBODY%3E%3C%2FTABLE%3E%3CP%3EMy%20formula%20input%20is%3A%20%3DCOUNTIFS(B1%3AB11%2C%22%20No%20findings%22%3B%20B1%3AB11%3B%22%20Rivet%22%3B%20B1%3AB11%3B%22%200.%20Not%20confirmed'%3B%20B1%3AB11%3B%22%20X.%20not%20available%22)%3C%2FP%3E%3CP%3EBut%20it%20doesn't%20work.%3C%2FP%3E%3CP%3EWhat%20am%20I%20doing%20wrong%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3028707%22%20slang%3D%22de-DE%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3028812%22%20slang%3D%22en-US%22%3ERe%3A%20Z%C3%A4hlen%20wenn%20eine%20oder%20mehrere%20Bezeichnungen%20m%C3%B6glich%20sind%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3028812%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1237108%22%20target%3D%22_blank%22%3E%40Josef38%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3DSUMMENPRODUKT(((B2%3AB11%3D%22Kein%20Befund%22)%2B(B2%3AB11%3D%22Niete%22)%2B(B2%3AB11%3D%22X.%20nicht%20vorhanden%22)))%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDas%20kann%20man%20mit%20Summenprodukt%20machen.%20In%20diesem%20Beispiel%20wird%20gez%C3%A4hlt%20wie%20oft%20Kein%20Befund%20oder%20Niete%20oder%26nbsp%3BX.%20nicht%20vorhanden%20vorkommt.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3028889%22%20slang%3D%22de-DE%22%3ERe%3A%20Count%20if%20one%20or%20more%20names%20are%20possible%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3028889%22%20slang%3D%22de-DE%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1174419%22%20target%3D%22_blank%22%3E%40Quadruple_Pawn%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20very%20much%20for%20the%20quick%20answer%2C%20which%20I%20tried%20right%20away.%3C%2FP%3E%3CP%3EWith%20the%20following%20result%3A%3C%2FP%3E%3CTABLE%20width%3D%22223%22%3E%3CTBODY%3E%3CTR%3E%3CTD%20width%3D%22143%22%3ENo%20findings%3C%2FTD%3E%3CTD%20width%3D%2280%22%3E%23NAME%3F%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3ERivet%3C%2FTD%3E%3CTD%3E%26nbsp%3B%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3EX.%20not%20available%3C%2FTD%3E%3CTD%3E%26nbsp%3B%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3E0.%20not%20confirmed%3C%2FTD%3E%3CTD%3E%26nbsp%3B%3C%2FTD%3E%3C%2FTR%3E%3C%2FTBODY%3E%3C%2FTABLE%3E%3CP%3EEntered%20Formula%3A%20%3DSUMPRODUCT(((((B1%3AB10%3D%22No%20finding%22)%2B(B1%3AB10%3DRivet)%2B(B1%3AB10%3D%22X.%20not%20present%22)%2B(B1%3AB10%3D%220.%20not%20present%22)))%3C%2FP%3E%3CP%3EI%20would%20like%20to%20have%20a%20number%20as%20a%20result.%3C%2FP%3E%3CP%3EAnother%20typo%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3028949%22%20slang%3D%22en-US%22%3ERe%3A%20Z%C3%A4hlen%20wenn%20eine%20oder%20mehrere%20Bezeichnungen%20m%C3%B6glich%20sind%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3028949%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1237108%22%20target%3D%22_blank%22%3E%40Josef38%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3DSUMMENPRODUKT(((B1%3AB10%3D%22Kein%20Befund%22)%2B(B1%3AB10%3D%3CFONT%20color%3D%22%23FF0000%22%3E%22%3C%2FFONT%3ENiete%3CFONT%20color%3D%22%23FF0000%22%3E%22%3C%2FFONT%3E)%2B(B1%3AB10%3D%22X.%20nicht%20vorhanden%22)%2B(B1%3AB10%3D%220.%20nicht%20vorhanden%22)))%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENur%20noch%20die%20Anf%C3%BChrungszeichen%20bei%20dem%20Kriterium%20%3CFONT%20color%3D%22%23FF0000%22%3E%22%3C%2FFONT%3ENiete%3CFONT%20color%3D%22%23FF0000%22%3E%22%26nbsp%3B%3C%2FFONT%3Edann%20klappt%20es.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hallo Zusammen,

ich möchte aus einer Spalte mit verschiedenen Texteinträgen in den Zellen diejenigen zählen, die ich für notwendig halte. z.B.

Kein Befund0
Niete 
0. Nicht bestätigt 
X. nicht vorhanden 

Meine Formeleingabe lautet: =ZÄHLENWENNS(B1:B11;"Kein Befund";B1:B11;"Niete";B1:B11;"0. Nicht bestätigt";B1:B11;"X. nicht vorhanden")

Funktioniert aber nicht.

Was mach ich falsch?

5 Replies

@Josef38 

=SUMMENPRODUKT(((B2:B11="Kein Befund")+(B2:B11="Niete")+(B2:B11="X. nicht vorhanden")))  

 

Das kann man mit Summenprodukt machen. In diesem Beispiel wird gezählt wie oft Kein Befund oder Niete oder X. nicht vorhanden vorkommt.

 

@Quadruple_Pawn 

 

Vielen Dank für die schnelle Antwort, die ich gleich ausprobiert habe.

Mit folgenden Ergebnis:

Kein Befund#NAME?
Niete 
X. nicht vorhanden 
0. nicht bestätigt 

Eingegeben Formel: =SUMMENPRODUKT(((B1:B10="Kein Befund")+(B1:B10=Niete)+(B1:B10="X. nicht vorhanden")+(B1:B10="0. nicht vorhanden")))

Ich hätte als Ergebnis gerne eine Zahl.

Noch ein Tippfehler?

@Josef38 

=SUMMENPRODUKT(((B1:B10="Kein Befund")+(B1:B10="Niete")+(B1:B10="X. nicht vorhanden")+(B1:B10="0. nicht vorhanden")))

 

Nur noch die Anführungszeichen bei dem Kriterium "Nietedann klappt es.

Super, vielen Dank nochmal für die schnelle Antwort!
LG

@Josef38 

Bitte schön. Freut mich das es Ihnen hilft. Freundliche Grüße.