xlookup issue

%3CLINGO-SUB%20id%3D%22lingo-sub-2158763%22%20slang%3D%22de-DE%22%3Exlookup%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2158763%22%20slang%3D%22de-DE%22%3E%3CP%3EExcel%20%3DXLOOKUP%20Formula%20is%20not%20working%20in%20German%20nor%20English%20version.%20It%20is%20not%20even%20recognised%20as%20a%20function.%20Already%20tried%20to%20reinstall%20and%20update%20Office%20and%20still%20the%20issue%20persists%20-%20please%20see%20reference%20number%201018036622.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2158763%22%20slang%3D%22de-DE%22%3E%3CLINGO-LABEL%3EExcel%20on%20Mac%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2158785%22%20slang%3D%22en-US%22%3ERe%3A%20xlookup%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2158785%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F975827%22%20target%3D%22_blank%22%3E%40MoselRheiderland%3C%2FA%3E%26nbsp%3BMS%20support%20writes%20the%20following%20with%20regard%20to%20XLOOKUP.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Screenshot%202021-02-23%20at%2012.47.20.png%22%20style%3D%22width%3A%20595px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F256979i7EC4B56B70FB3309%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Screenshot%202021-02-23%20at%2012.47.20.png%22%20alt%3D%22Screenshot%202021-02-23%20at%2012.47.20.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EAre%20you%20using%20Excel%20for%20MS365%20for%20Mac%3F%20If%20not%2C%20that's%20why%20you%20don't%20have%20it.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Excel =XLOOKUP Formula is not working in German nor English version. It is not even being recognised as a function. Already tried to reinstall and update Office and still the issue persists - please see reference number 1018036622.

7 Replies

@MoselRheiderland MS support writes the following with regard to XLOOKUP.

Screenshot 2021-02-23 at 12.47.20.png

Are you using Excel for MS365 for Mac? If not, that's why you don't have it.

@Riny_van_Eekelen Well, I bought an MS365 licence and have an annual subscrition plan. I downloaded the installation files via the "Download Office"-Button at office.com while I was logged in, so I assumed it had to be the MS365 version. If I go to Excel > Info it says "Microsoft Excel für Mac" and "Version 16.46" which is the most recent as far as I know. So it should be MS365, shouldn't it?

Is there any other reliable way to check, what exact product I am currently using?

@MoselRheiderland Perhaps dumb suggestion, but did you try XVERWEIS ?

@Riny_van_Eekelen Yes, I have

I also used the function generator to look for it in case I misspelled something, but it doesn't show the function, neither in german nor in english.

@MoselRheiderland 

Strange! 

In the Help meny, Check for updates. Then "Advanced". Which channel are you on (Current, Current Preview or Beta). I'm running Excel on different Mac, both in Current and Beta channel. Both have =XLOOKUP since several months ago. You should have it also.

@Riny_van_Eekelen Strange indeed. There are no updates available, it is running the newest version and the Update Channel is "Current".

I also have the feeling, nobody else seems to have this problem. This usually indicates I made a very obvious mistake, but I just cannot find it. The MacOS I'm running it on is Catalina 10.15.7 (minimum is Mojave 10.14) so that isn't the problem either...

@Riny_van_Eekelen The problem has been solved! Our Technician suggested using an app cleaner to deinstall the current office installation completely and reinstall it via the AppStore instead of downloading the installation file and IT WORKED. The layout has changed slightly and the XVERWEIS function is available.

 

Thank you very much for your help and suggestions in the process!