Vlookup

%3CLINGO-SUB%20id%3D%22lingo-sub-2572216%22%20slang%3D%22en-US%22%3EVlookup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2572216%22%20slang%3D%22en-US%22%3E%3CP%3EHello!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20working%20on%20a%20monthly%20report%2C%20and%20I%20have%20a%20vlookup%20that%20is%20not%20behaving%20as%20expected.%20In%20the%20previous%20month's%20report%20I%20have%20a%20vlookup%20formula%20(%3DVLOOKUP(G2%2C%20Lookup!A%3AB%2C%202%2C%20FALSE)%20that%20pulls%20data%20from%20a%20tab%20in%20the%20report%20labeled%20%22Lookup%22.%20In%20the%20current%20month's%20report%2C%20I%20created%20a%20copy%20of%20that%20same%20%22Lookup%22%20tab%20entered%20all%20the%20same%20information%20and%20an%20identical%20formula%20and%20for%20some%20reason%20I%20am%20returning%20only%20%23N%2FA's%20even%20though%20it%20is%20identical%20to%20the%20previous%20month's%20report%20that%20pulled%20data%20correctly.%20I%20have%20tried%20everything%20I%20can%20think%20of%20to%20confirm%20that%20the%20data%20and%20formulas%20are%20all%20identical%2C%20so%20I%20am%20not%20sure%20why%20it%20is%20unable%20to%20pull%20the%20data%20I%20need.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2572216%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%20on%20Mac%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2572260%22%20slang%3D%22en-US%22%3ERe%3A%20Vlookup%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2572260%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1109439%22%20target%3D%22_blank%22%3E%40OliviaCapizzi%3C%2FA%3E%3C%2FP%3E%0A%3CP%3EMake%20sure%20that%20there%20aren't%20extra%20spaces%20before%20or%20after%20the%20data%20that%20you're%20looking%20up.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20you%20wish%2C%20you%20can%20attach%20a%20sample%20workbook%20demonstrating%20the%20problem%20to%20a%20reply.%20Don't%20include%20any%20sensitive%20data%20in%20the%20sample%20workbook.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hello! 

 

I am working on a monthly report, and I have a vlookup that is not behaving as expected. In the previous month's report I have a vlookup formula (=VLOOKUP(G2, Lookup!A:B, 2, FALSE) that pulls data from a tab in the report labeled "Lookup". In the current month's report, I created a copy of that same "Lookup" tab entered all the same information and an identical formula and for some reason I am returning only #N/A's even though it is identical to the previous month's report that pulled data correctly. I have tried everything I can think of to confirm that the data and formulas are all identical, so I am not sure why it is unable to pull the data I need. 

1 Reply

@OliviaCapizzi

Make sure that there aren't extra spaces before or after the data that you're looking up.

 

If you wish, you can attach a sample workbook demonstrating the problem to a reply. Don't include any sensitive data in the sample workbook.