SOLVED

Vlookup only works halfway and rest is #N/A

Copper Contributor

Hi everyone,

 

So I'm having this issue lately with documents that I export from our ordering/Bookkeeping system. I want to use vlookup to see which client has ordered which amount of product X and put everything in 1 list. Now I use vlookup and it works for the first few rows, then it stops. If I start midway somewhere in my list, again first few work and others don't. I tried everything I could find online, so please don't come up with solutions to use TRIM, CLEAN, combining INDEX & MATCH, putting everything in same format..... It's super strange and I tried copy pasting the entire sheet to new clean sheet, because I thought maybe something went wrong in the export. In any case it doesn't work and I have spent several hours trying to fix it. Would be very happy if someone knew why this is or has had similar issues and has some solutions? 

 

Thank you!! 

2 Replies
best response confirmed by Hans Vogelaar (MVP)
Solution

@Lena_Chatchatrian 

I'd guess that the $ signs are missing in the matrix of VLOOKUP. Which means you have something like

=VLOOKUP(A2,E2:F22,2,FALSE)

instead of

=VLOOKUP(A2,$E$2:$F$22,2,FALSE)

@OliverScheurich thank you so much!!! it worked :) 

1 best response

Accepted Solutions
best response confirmed by Hans Vogelaar (MVP)
Solution

@Lena_Chatchatrian 

I'd guess that the $ signs are missing in the matrix of VLOOKUP. Which means you have something like

=VLOOKUP(A2,E2:F22,2,FALSE)

instead of

=VLOOKUP(A2,$E$2:$F$22,2,FALSE)

View solution in original post