vlookup not working.

%3CLINGO-SUB%20id%3D%22%5C%26quot%3Blingo-sub-3151497%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3Evlookup%20not%20working.%26lt%3B%5C%2Flingo-sub%26gt%3B%3CLINGO-BODY%20id%3D%22%5C%26quot%3Blingo-body-3151497%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3E%3CP%3Evlookup%20stopped%20working%20even%20in%20spreadsheets%20where%20it%20has%20worked%20before.%26nbsp%3B%20%26nbsp%3Bwhen%20i%20hit%20%22OK%22%20after%20entering%20the%20data%20(it%20shows%20it%20has%20found%20the%20correct%20corresponding%20info)%20the%20function%20just%20hangs%20and%20does%20nothing.%26nbsp%3B%20Neither%20the%20OK%20or%20Cancel%20button%20do%20anything.%26nbsp%3B%20I%20have%20to%20x%20out.%26lt%3B%5C%2FP%26gt%3B%26lt%3B%5C%2Flingo-body%26gt%3B%3CLINGO-LABS%20id%3D%22%5C%26quot%3Blingo-labs-3151497%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3E%3CLINGO-LABEL%3EExcel%26lt%3B%5C%2Flingo-label%26gt%3B%3CLINGO-LABEL%3EFormulas%20and%20Functions%26lt%3B%5C%2Flingo-label%26gt%3B%3CLINGO-LABEL%3EOffice%20365%26lt%3B%5C%2Flingo-label%26gt%3B%26lt%3B%5C%2Flingo-labs%26gt%3B%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3C%2FLINGO-SUB%3E
New Contributor

vlookup stopped working even in spreadsheets where it has worked before.   when i hit "OK" after entering the data (it shows it has found the correct corresponding info) the function just hangs and does nothing.  Neither the OK or Cancel button do anything.  I have to x out.

5 Replies

@Bill_Bevers 

That's better with sample. "it has worked before" - stopped to work on the same version of Excel or after you updated on dynamic arrays ? It doesn't work in the concrete file or in any workbook? Etc, etc. Just sample could answer on many questions.

@Sergei Baklan 

 

Screenshot 2022-02-11 094058.png

 here is a screen shot of the problem.  when i hit OK it hangs and I have to x out.  you can see it found the correct arguements.  how do i attach or send the spreadsheet?

@Bill_Bevers 

If this option

image.png

is not available, you may share on OneDrive or like; or send Direct Message to me with file

@Bill_Bevers , thank you for the file. Unfortunately there was no formula in it you try to use. Anyway, I added formula and it works, please check attached.

 

Back to your screenshot

image.png

As variant Show Formulas is switched on in your file, perhaps something else.

 

Or you never clicked on Ok here

image.png

Above doesn't evaluate entire formula, it show you results for arguments (false in this case).

thanks, looks like the formula has changed and "false" is not a valid argument anymore. I have used "false" many times as the last arguement. The prompt used to say "false" returns the value in the lookup table. Thanks for your help. Mine works now if i dont say false