visual basic-code is incompatible with the version, platform or architecture

%3CLINGO-SUB%20id%3D%22lingo-sub-2265384%22%20slang%3D%22en-US%22%3Evisual%20basic-code%20is%20incompatible%20with%20the%20version%2C%20platform%20or%20architecture%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2265384%22%20slang%3D%22en-US%22%3E%3CP%3Ecode%20is%20incompatible%20with%20the%20version%2C%20platform%20or%20architecture%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2265384%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%20on%20Mac%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

code is incompatible with the version, platform or architecture

1 Reply

@casefam2verizonnet 

It could be that there is an "outdated" macro at the start that is not compatible with the existing version of Office.

You can deactivate the macro function in the settings of Excel to see whether it is of it.

 

Steps:

In Excel -> File -> Options -> Security Center -> Settings for the Security Center -> Settings for Macros.

 

If this does not solve the problem, follow the links step by step through the different methides that are offered.

 

You receive a "Compile error in hidden module" error message when you start Word or Excel

To view the details of the error signature, click the link To see what data this error report contains, click here in the error dialog box.

 

Compile error in hidden module

A protected module contains a compilation error. Because the error is in a protected module it cannot be displayed.

 

If the methods suggested by Microsoft did not help you either, then I recommend that you uninstall Office entirely and then reinstall it.

 

I would be happy to know if I could help.

 

Nikolino

I know I don't know anything (Socrates)

 

* Kindly Mark and Vote this reply if it helps please, as it will be beneficial to more Community members reading here.