#VALUE!

%3CLINGO-SUB%20id%3D%22lingo-sub-2422930%22%20slang%3D%22en-US%22%3E%23VALUE!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2422930%22%20slang%3D%22en-US%22%3E%3CP%3EWhy%20has%20Excel%2C%20*all%20of%20a%20sudden%2C*%20started%20giving%20an%20error%20flag%20when%20doing%20simple%20mathematics%20that%20it%20had%20not%20done%20before.%26nbsp%3B%20By%20adding%20%3Dif(H5%3D%22%22%2CI4%2CH5%2BI4).%3C%2FP%3E%3CP%3EIf%20the%20cell%20contains%20an%20EMPTY%20cell%2C%20no%20spaces%2C%20nothing%2C%20it%20gives%20%23VALUE!.%26nbsp%3B%20What%20happened%20from%20last%20week%20to%20this%20week%20that%20has%20created%20this%20agonizing%20blooper!%3C%2FP%3E%3CP%3EI%20really%20do%20not%20want%20to%20show%20a%20zillow%200's%20when%20the%20cell%20is%20empty.%3C%2FP%3E%3CP%3EI%20have%20also%20tried%20IFERROR%20with%20no%20change.%3C%2FP%3E%3CP%3EWhat%20has%20Excel%20done%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHELP!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2422930%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2423027%22%20slang%3D%22en-US%22%3ERe%3A%20%23VALUE!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2423027%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1073091%22%20target%3D%22_blank%22%3E%40DennaB%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3EWhat%20has%20Excel%20done%3F%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EProbably%20nothing.%20It's%20generally%20premature%20to%20place%20the%20blame%20on%20Excel%2C%20especially%20when%20it%20comes%20to%20something%20as%20simple%20as%20adding%20two%20cells%2C%20even%20if%20you%20think%20that%20nothing%20has%20changed%20at%20your%20end.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20guess--especially%20since%20you%20mention%20Zillow%20in%20the%20process%20of%20your%20message--%20is%20that%20%3CEM%3Esomething%3C%2FEM%3E%20%3CSTRONG%3EHAS%3C%2FSTRONG%3E%20changed%20at%20your%20end%20of%20things%20in%20those%20cells%20that%20are%20to%20be%20added.%20Especially%20if%20you%20are%20importing%20a%20CSV%20file%20from%20a%20source%20outside.%20There%20may%20be%20special%20characters%20embedded.....%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20it%20possible%20to%20post%20a%20copy%20of%20your%20spreadsheet%20in%20which%20this%20is%20happening%3F%20Not%20an%20image%3B%20the%20actual%20spreadsheet.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAbsent%20that%2C%20describe%20a%20bit%20more%20fully%20the%20whole%20process%20prior%20to%20this%20error%3A%20in%20particular%2C%20where%20the%20data%20in%20cells%20H5%20and%20I4%20is%20coming%20from%2C%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2423066%22%20slang%3D%22en-US%22%3ERe%3A%20%23VALUE!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2423066%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F425987%22%20target%3D%22_blank%22%3E%40mathetes%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20recall%20specifying%20%22Zillow%22%20in%20my%20prior%20message.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELet%20me%20update%20the%20spreadsheet%20as%20it's%20currently%20my%20personal%20checkbook%20and%20do%20not%20want%20to%20disclose%20that%20much%20of%20my%20personal%20details.%26nbsp%3B%20Then%20I'll%20upload%20a%20modified%20copy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20cells%20are%20empty%2C%20I've%20already%20checked.%26nbsp%3B%20No%20extra%20spaces%2C%20I've%20already%20checked.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20do%20not%20know%20if%20it%20was%20Excel%20...%20but%20do%20not%20know%20where%20else%20to%20point.%26nbsp%3B%20%3CLI-EMOJI%20id%3D%22lia_slightly-smiling-face%22%20title%3D%22%3Aslightly_smiling_face%3A%22%3E%3C%2FLI-EMOJI%3E%26nbsp%3B%20Thought%20it%20might%20have%20been%20one%20of%20those%20automatic%20updates.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2423072%22%20slang%3D%22en-US%22%3ERe%3A%20%23VALUE!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2423072%22%20slang%3D%22en-US%22%3EIn%20this%20particular%20spreadsheet%2C%20I%20do%20not%20import%20any%20CSV%20file.%20It's%20strictly%20typing%20in%20details%2C%20or%20copy%2Fpasting%20from%20a%20previous%20line.%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2423074%22%20slang%3D%22en-US%22%3ERe%3A%20%23VALUE!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2423074%22%20slang%3D%22en-US%22%3EP.S.%20Typo%3A%20Not%20zillow%2C%20it%20was%20suppose%20to%20be%20an%20exaggeration%20%22zillion.%22%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2423093%22%20slang%3D%22en-US%22%3ERe%3A%20%23VALUE!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2423093%22%20slang%3D%22en-US%22%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1073091%22%20target%3D%22_blank%22%3E%40DennaB%3C%2FA%3E%20%2C%3CBR%20%2F%3E%3CBR%20%2F%3E%23VALUE%20means%20the%20value%20is%20nothing%2C%20you%20have%20a%20wrong%20formula.%20Read%20everything%20slowly%20and%20you%20find%20the%20mistake%20in%20less%20than%205%20minutes%20%3CLI-EMOJI%20id%3D%22lia_grinning-face-with-smiling-eyes%22%20title%3D%22%3Agrinning_face_with_smiling_eyes%3A%22%3E%3C%2FLI-EMOJI%3E%3CBR%20%2F%3E%3CBR%20%2F%3EBest%20regards%2C%3CBR%20%2F%3ESchnittlauch%3CBR%20%2F%3E%3CBR%20%2F%3E%22First%2C%20No%20system%20is%20safe.%20Second%2C%20Aim%20for%20the%20impossible.%20Third%20no%20Backup%2C%20no%20Mercy%22%20-%20Schnittlauch%3CBR%20%2F%3E%3CBR%20%2F%3EMy%20answer%20helped%20you%3F%20Don't%20forget%20to%20leave%20a%20like.%20Also%20mark%20the%20answer%20as%20solved%20when%20your%20problem%20is%20solved.%20%3CLI-EMOJI%20id%3D%22lia_slightly-smiling-face%22%20title%3D%22%3Aslightly_smiling_face%3A%22%3E%3C%2FLI-EMOJI%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Why has Excel, *all of a sudden,* started giving an error flag when doing simple mathematics that it had not done before.  By adding =if(H5="",I4,H5+I4).

If the cell contains an EMPTY cell, no spaces, nothing, it gives #VALUE!.  What happened from last week to this week that has created this agonizing blooper!

I really do not want to show a zillow 0's when the cell is empty.

I have also tried IFERROR with no change.

What has Excel done?

 

HELP!

 

 

12 Replies

@DennaB 

 

What has Excel done?

 

Probably nothing. It's generally premature to place the blame on Excel, especially when it comes to something as simple as adding two cells, even if you think that nothing has changed at your end.

 

My guess--especially since you mention Zillow in the process of your message-- is that something HAS changed at your end of things in those cells that are to be added. Especially if you are importing a CSV file from a source outside. There may be special characters embedded.....

 

Is it possible to post a copy of your spreadsheet in which this is happening? Not an image; the actual spreadsheet.

 

Absent that, describe a bit more fully the whole process prior to this error: in particular, where the data in cells H5 and I4 is coming from,

@mathetes 

 

I don't recall specifying "Zillow" in my prior message.

 

Let me update the spreadsheet as it's currently my personal checkbook and do not want to disclose that much of my personal details.  Then I'll upload a modified copy.

 

The cells are empty, I've already checked.  No extra spaces, I've already checked.

 

I do not know if it was Excel ... but do not know where else to point.    Thought it might have been one of those automatic updates.

 

 

 

In this particular spreadsheet, I do not import any CSV file. It's strictly typing in details, or copy/pasting from a previous line.
P.S. Typo: Not zillow, it was suppose to be an exaggeration "zillion."
Hi @DennaB ,

#VALUE means the value is nothing, you have a wrong formula. Read everything slowly and you find the mistake in less than 5 minutes

Best regards,
Schnittlauch

"First, No system is safe. Second, Aim for the impossible. Third no Backup, no Mercy" - Schnittlauch

My answer helped you? Don't forget to leave a like. Also mark the answer as solved when your problem is solved.

@DennaB 

Let me update the spreadsheet as it's currently my personal checkbook and do not want to disclose that much of my personal details. Then I'll upload a modified copy.

In my own spreadsheet for tracking personal income and expenses, the data--checks written, credit card payments, etc--are all imported from the various banks (in CSV form usually). So I don't actually enter any. I add columns for Budget Category and Sub-Categories, then use Pivot Table to summarize by month and categories, all the income and expense lines. It's something I created on my own.

It's strictly typing in details, or copy/pasting from a previous line. The cells are empty, I've already checked. No extra spaces, I've already checked.

There is something in one or both of the cells, or possibly in the formatting of one or both of them, that causes Excel to give you the #VALUE message. Are the older lines in the check register still working, or have all of them gone wrong.

I do not know if it was Excel ... but do not know where else to point. Thought it might have been one of those automatic updates.

My only point was that you're not going to find the cause for that problem in Excel itself. That would mean that millions (zillions?) of people all over the world would suddenly be experiencing #VALUE errors in their spreadsheets. It would be on the front pages of the Wall Street Journal.  Which means, as @Schnittlauch has suggested, just go slowly through the formula (even try a different formula or two in the same cell, using the same cells) and the raw data. You'll find the cause a lot closer to home.

 

 

@mathetes 

 

Yes, of course I realize that Microsoft would be bombarded with complaints and all over the News. 

 

I'm very frustrated as it's one of those crazy things.   I would REALLY like to upload a version of the worksheet as I'm totally stumped.  To make it worse, being blessed with reaching the age of 77 this month, I'm a retired SAS/SQL programmer on UNIX & PC, using macros in Excel.  This is incredibly embarrassing.
attached is a modified copy with text removed and the numbers changed to be unreal.

AnImage_testExcel_Spreadsheet.jpg

@mathetes

Here is what it looks like with artificial numbers.  I cannot even figure how to upload my workbook.

                        500.00 
1-JanOnline    50.00                 550.00 
1-JanDeposit                    50.00                 600.00 
1-JanDeposit                    50.00                 650.00 
5-Jan2078     75                575.00 
5-JanOnline      75#VALUE! 
5-JanOnline     75#VALUE! 
5-JanOnline     75#VALUE! 
7-JanOnline     75#VALUE! 
7-JanOnline     75#VALUE! 
7-JanOnline     25#VALUE! 
7-JanISSUED     75#VALUE! 
8-Jan2075     75#VALUE! 
12-JanOnline      25#VALUE! 
12-JanOnline     25#VALUE! 
14-JanOnline     25#VALUE! 
17-JanOnline     75#VALUE! 
17-JanOnline     75#VALUE! 
17-JanOnline      #VALUE! 
21-JanOnline     75#VALUE! 
21-JanOnline    75.00 #VALUE! 
21-JanOnline     75#VALUE! 
21-JanScheduled    7575#VALUE! 
22-JanDeposit       #VALUE! 
26-JanOnline     75#VALUE! 
26-JanOnline                    50.00 #VALUE! 
27-JanOnline       #VALUE! 
29-JanDeposit    50.00 #VALUE! 
29-Jan      $             75.00 #VALUE! 
1-FebDeposit                    50.00 #VALUE! 

@DennaB 

 

I can share in your blessing, but in my case three years ahead of you and still a few months away==I'll turn 80 in October.  I also share some of your experience as well--it wasn't my main career, but I did become something of a power user with Excel and its predecessors in the spreadsheet world (Lotus, Quattro), as well as learning SQL to write extensive queries from a mainframe database--and therefore can fully appreciate how frustrating it can be when, with all that experience, you can't put your finger on what's causing the #VALUE.

 

Unfortunately, an image isn't something that any of us can actually do much diagnostic work with.

 

Looking at the formula in the formula bar in the image, and the cell from which it appears to come (I748), I can tell:

  • the formula IS working in I748
  • and it's not in any of the subsequent rows--well, more precisely, it's working to deliver #VALUE

 

Which suggest something I'm sure you're well aware of, that the issue is most likely in whatever is in cells G749 and H749...and once introduced it doesn't self-correct since it's always in I749, I750, I751,... and on. Has the formula been changed in any way in any of the rows? I will offer the observation that the formula that's visible in this image is NOT the formula you included in your original post.

 

What happens if you place fresh numeric values in some of the cells in columns G, H and I down below where the #VALUE first appears? Down in the 760s?  

 

And since you made this image from a modified copy of the spreadsheet itself, is it now possible to post that actual--but modified and therefore not revealing sensitive personal data--spreadsheet?

Thank you SO much. Oh my. Lotus 1-2-3 and Quattro!!! I haven't heard those product names in YEARS. I loved Lotus 1-2-3 and Quattro was such a great and simple database.

I'll research the worksheet/spreadsheet and see if I can follow your suggestions.
At least I've learned to Knit. Hahaha.
P.S. Bet you were familar with Paradox, too. Another neat little database.

@DennaB 

 

To post an actual spreadsheet, you first go to the reply window

mathetes_0-1623170259482.png

 

then, down at the bottom, select "Open Full Text Editor" 

 

And at the bottom of the full text editor you'll see an area into which you can just Drag and Drop a copy of the full Excel file. It looks like this.

mathetes_1-1623170330344.png

And then click on "Post"