Use of asterix in GETPIVOTDATA

%3CLINGO-SUB%20id%3D%22lingo-sub-2976676%22%20slang%3D%22en-US%22%3EUse%20of%20asterix%20in%20GETPIVOTDATA%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2976676%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20I%20am%20using%20the%20GETPIVOTDATA%20function%20to%20get%20information%20in%20a%20table.%3C%2FP%3E%3CP%3EI%20change%20the%20arguments%20with%20specific%20cells%20%24A%243%20instead%20of%20the%20name%20of%20the%20argument.%3C%2FP%3E%3CP%3EIn%20line%2017%2C%20I%20want%20to%20have%20the%20result%20of%20every%20reception%20in%20december%2C%20year%202020%2C%20for%20the%204%20criterias%20you%20can%20see%20in%20purple.%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20is%20my%20function%20(it%20is%20in%20french)%20%3A%3C%2FP%3E%3CP%3E%3DSIERREUR(LIREDONNEESTABCROISDYNAMIQUE(%22Somme%20de%20QtyReception%22%3B'TCD%20R%C3%A9ceptions'!%24A%241%3B%22AnneeFinanciere%22%3B%24B%2411%3B%22MoisFinancier%22%3BB%2413%3B%22Univers%22%3B%24C%241%3B%22Division%22%3B%24C%242%3B%22Classe%22%3B%24C%244%3B%22Capsule%22%3B%24C%243)%3B0)%3C%2FP%3E%3CP%3EFor%20the%20moment%20it%20works%20well%2C%20but%20I%20would%20like%20to%20use%20an%20asterix%20*%20instead%20of%20ROBE%2FDRESS%20to%20see%20the%20data%20for%20only%203%20criterias%2C%20instead%20of%204%2C%20but%20I%20get%20an%20error%20code.%3C%2FP%3E%3CP%3EI%20already%20used%20the%20asterix%20in%20OLAP%20PIVOT%20TABLE%20and%20it%20worked%20perfectly.%3C%2FP%3E%3CP%3EIs%20there%20an%20equivalent%20option%20I%20can%20use%20instead%20of%20the%20*%20%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Makajo_0-1637172381770.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F327697iBF991F6D6808AF91%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Makajo_0-1637172381770.png%22%20alt%3D%22Makajo_0-1637172381770.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EThank%20you!!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2976676%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

Hi, I am using the GETPIVOTDATA function to get information in a table.

I change the arguments with specific cells $A$3 instead of the name of the argument.

In line 17, I want to have the result of every reception in december, year 2020, for the 4 criterias you can see in purple. 

Here is my function (it is in french) :

=SIERREUR(LIREDONNEESTABCROISDYNAMIQUE("Somme de QtyReception";'TCD Réceptions'!$A$1;"AnneeFinanciere";$B$11;"MoisFinancier";B$13;"Univers";$C$1;"Division";$C$2;"Classe";$C$4;"Capsule";$C$3);0)

For the moment it works well, but I would like to use an asterix * instead of ROBE/DRESS to see the data for only 3 criterias, instead of 4, but I get an error code.

I already used the asterix in OLAP PIVOT TABLE and it worked perfectly.

Is there an equivalent option I can use instead of the * ?

Makajo_0-1637172381770.png

Thank you!!

 

0 Replies