Unable to assign any new buttons

New Contributor

Excel for Mac 2011.  version 14.7.3 (170325).  Last Update 14.7.3

Running on Macbook OS High Sierra

 

Hi. I wrote a program for our Golf Society handicaps back in 1990 and this is still running well following many updates etc. It includes buttons set up before VB which work OK.  However, now I cannot assign any new buttons to macros. - see screenshot attached.  

1. Is there an update to fix this problem.

2. Do I need to update Excel and if so, will a new version run my older programs. I think I may also have to move on from High Sierra?

 

 

4 Replies

@Bob_Jones9 You didn't attach a screenshot. Please try again.

 

Sorry. Attached now.

@Bob_Jones9 Thanks! That brings back memories. Haven't worked with that version for a long long time. Still have an old iMac with 2011 on it. The message suggest you are trying to do something "too complex". Can't really tell what that would be without the file, though.

 

 

That was originally written in Lotus123!! Anyway, I have tried on new files with just one line of simple code, created the button but on assigning the button to the macro I get this result, so it seems more system than user. Also, I got a pal to create the same on his up to date version and microsoft OS. Worked for him but on trying to open his attachment on my system, that part is unreadable.