Trasformare un campo in chiave in cui non possano esistere DUPLICATI

%3CLINGO-SUB%20id%3D%22lingo-sub-2403592%22%20slang%3D%22en-US%22%3ETrasformare%20un%20campo%20in%20chiave%20in%20cui%20non%20possano%20esistere%20DUPLICATI%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2403592%22%20slang%3D%22en-US%22%3E%3CP%3EBuongiorno%2C%20mi%20scuso%20se%20scrivo%20in%20ITALIANO%20ma%20l'argomento%20non%20e'%20semplice%20per%20essere%20tradotto%20in%20English.%26nbsp%3B%20Ho%20la%20necessit%C3%A0%20di%20assegnare%20ad%20una%20colonna%20EXCEL%20la%20caratteristica%20di%20essere%20un%20campo%20CHIAVE%20in%20modo%20tale%20che%20i%20valori%20inseriti%20(numerici%20o%20alfanumerici)%20NOPN%20POSSANO%20MAI%20ESSERE%20DUPLICATI.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EE'%20possibile%3F%20come%3F%20Grazie%2C%20Enrico%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2403592%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2403813%22%20slang%3D%22en-US%22%3ERe%3A%20Trasformare%20un%20campo%20in%20chiave%20in%20cui%20non%20possano%20esistere%20DUPLICATI%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2403813%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1068259%22%20target%3D%22_blank%22%3E%40EnricoGanassi%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%C3%88%20molto%20difficile%20escludere%20completamente%20i%20duplicati%2C%20ma%20puoi%20fare%20quanto%20segue.%3CBR%20%2F%3ESupponiamo%20che%20tu%20non%20voglia%20duplicati%20nella%20colonna%20A.%3CBR%20%2F%3ESelezionare%20la%20colonna%20A.%3CBR%20%2F%3ENella%20scheda%20Dati%20della%20barra%20multifunzione%2C%20selezionare%20'Convalida%20dati'.%3CBR%20%2F%3ESelezionare%20Personalizzato%20dall'elenco%20Consenti.%3CBR%20%2F%3EInserisci%20la%20formula%3CBR%20%2F%3E%3DCONTA.SE(A%3AA%2CA1)%3D1%3CBR%20%2F%3ESelezionarela%20scheda%20'Avviso%20errore'.%3CBR%20%2F%3EInserisci%20un%20messaggio%20appropriato.%3CBR%20%2F%3ESelezionare%20OK.%3CBR%20%2F%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Buongiorno, mi scuso se scrivo in ITALIANO ma l'argomento non e' semplice per essere tradotto in English.  Ho la necessità di assegnare ad una colonna EXCEL la caratteristica di essere un campo CHIAVE in modo tale che i valori inseriti (numerici o alfanumerici) NOPN POSSANO MAI ESSERE DUPLICATI.

 

E' possibile? come? Grazie, Enrico

1 Reply

@EnricoGanassi

È molto difficile escludere completamente i duplicati, ma puoi fare quanto segue.
Supponiamo che tu non voglia duplicati nella colonna A.
Selezionare la colonna A.
Nella scheda Dati della barra multifunzione, selezionare 'Convalida dati'.
Selezionare Personalizzato dall'elenco Consenti.
Inserisci la formula
=CONTA.SE(A:A,A1)=1
Selezionarela scheda 'Avviso errore'.
Inserisci un messaggio appropriato.
Selezionare OK.