SOLVED

Transpose function returns #VALUE

%3CLINGO-SUB%20id%3D%22lingo-sub-1610736%22%20slang%3D%22en-US%22%3ETranspose%20function%20returns%20%23VALUE%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1610736%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20in%20desperate%20need%20of%20help.%20I%20have%20searched%20the%20transpose%20problems%20but%20have%20not%20seen%20an%20issue%20like%20mine.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20trying%20to%20do%20a%20matrix%2C%20using%20MMULT%20and%20TRANSPOSE%20but%20it%20keeps%20returning%20%23VALUE.%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20code%20I%20am%20running%20is%3A%3C%2FP%3E%3CP%3E%3DMMULT(ARRAY%3BTRANSPOSE(ARRAY))%3C%2FP%3E%3CP%3EI%20have%20correctly%20selected%20all%20the%20cells%20and%20pressed%20command%20%2B%20Enter%20but%20it%20still%20gives%20me%20%23VALUE.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20just%20using%20the%20Transpose%20function%20as%20a%20test%20and%20that%20also%20doesnt%20seem%20to%20be%20working%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20attached%20the%20excel%20sheet%20I%20am%20using.%20Cell%20references%20AF320%3AAN328%20this%20is%20where%20i%20am%20trying%20to%20put%20the%20matrix.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYour%20help%20will%20be%20greatly%20appreciated%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1610736%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%20on%20Mac%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1610764%22%20slang%3D%22en-US%22%3ERe%3A%20Transpose%20function%20returns%20%23VALUE%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1610764%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F770503%22%20target%3D%22_blank%22%3E%40Kayllen%3C%2FA%3E%26nbsp%3BNot%20sure%20what%20you%20are%20trying%20to%20achieve%2C%20but%20when%20I%20opened%20your%20file%20there%20were%20several%26nbsp%3B%40-signs%20in%20the%20formula%20in%20AF320.%20Removed%20these%20and%20then%20cleared%20all%20the%20other%20cells%20below%20and%20to%20the%20right.%3C%2FP%3E%3CP%3EThen%20numbers%20appeared%20in%20the%20range%20AF320%3AAN328.%20Is%20that%20what%20you%20need%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1610795%22%20slang%3D%22en-US%22%3ERe%3A%20Transpose%20function%20returns%20%23VALUE%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1610795%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F770503%22%20target%3D%22_blank%22%3E%40Kayllen%3C%2FA%3E%26nbsp%3BAttache%20your%20file%20after%20removing%20the%26nbsp%3B%40's.%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Screenshot%202020-08-25%20at%2017.04.27.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F214645i1CD3A6B192048136%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Screenshot%202020-08-25%20at%2017.04.27.png%22%20alt%3D%22Screenshot%202020-08-25%20at%2017.04.27.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1610782%22%20slang%3D%22en-US%22%3ERe%3A%20Transpose%20function%20returns%20%23VALUE%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1610782%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F403176%22%20target%3D%22_blank%22%3E%40Riny_van_Eekelen%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20not%20sure%20what%26nbsp%3B%40%20signs%20you%20are%20referring%20to.%20I%20have%20attached%20a%20screenshot%20of%20what%20I%20am%20seeing%20in%20the%20formula%20bar.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi all,

 

I am in desperate need of help. I have searched the transpose problems but have not seen an issue like mine. 

 

I am trying to do a matrix, using MMULT and TRANSPOSE but it keeps returning #VALUE. 

The code I am running is:

=MMULT(ARRAY;TRANSPOSE(ARRAY))

I have correctly selected all the cells and pressed command + Enter but it still gives me #VALUE.

 

I have tried just using the Transpose function as a test and that also doesnt seem to be working

 

I have attached the excel sheet I am using. Cell references AF320:AN328 this is where i am trying to put the matrix.

 

Your help will be greatly appreciated

 

7 Replies
Highlighted

@Kayllen Not sure what you are trying to achieve, but when I opened your file there were several @-signs in the formula in AF320. Removed these and then cleared all the other cells below and to the right.

Then numbers appeared in the range AF320:AN328. Is that what you need?

Highlighted

Hi, @Riny_van_Eekelen 

 

I am not sure what @ signs you are referring to. I have attached a screenshot of what I am seeing in the formula bar. 

 

 

Highlighted
Best Response confirmed by Kayllen (New Contributor)
Solution

@Kayllen Attache your file after removing the @'s.Screenshot 2020-08-25 at 17.04.27.png

 

Highlighted

Hi @Riny_van_Eekelen 

 

Thank you.

 

Could there be a setting in my excel that could be causing this issue of the @ signs that I am not inputing nor can i view them in the formula?

 

 

Highlighted

@Kayllen Not sure. Not an expert one why and when the @-signs appear. What Excel version are you on? 

 

Highlighted

@Kayllen 

What is your desired output in AF320:AF328?

Highlighted

Hi, @Detlef Lewin 

 

The desired outcome is meant to be a 9x9 matrix. I have since then come right. 

 

Thanks.