suche Excel formel

Visitor

Hallo Zusammen,

 

ich habe folgendes Problem:

Ich möchte bestimmte Verknüpfungen erstellen zwischen den jeweiligen Quartalsübersichten und der Gesamttabelle.

Situation:

Ich möchte sobald ein Mitarbeiter, eine Leistung, ein Einkauf etc. eingetragen wird, dieses automatisch vom Tabellenblatt Gesamt ins Tabellenblatt X erscheint. Nur leider ist es schwer, wenn diese mehrere Quartale in Anspruch nehmen.

Siehe Beispiel unten:

Lisa033_0-1662553871681.png

 

Es erscheint nur Marina in Quartal 1, obwohl Olaf und Schulz ebenfalls dazu gehören.

 

Lisa033_1-1662553890017.png

 

Ich habe mit folgender Formel gearbeitet: =WENN($B$2='Gesamt Jahr'!D2;'Gesamt Jahr'!A2;"")

 

Das zweite Problem ist, dass die Marina erst in der 7. Zeile erscheint, anstatt in der 5. Zeile.

 

Kann mir jemand da weiterhelfen?

 

Vielen Dank und freundliche Grüße

Lisa

2 Replies

@Lisa033 You need FILTER() function. See the attached file.

=FILTER(Sheet1!A2:A6,ISNUMBER(SEARCH(B2,Sheet1!D2:D6)))

 

@Lisa033 

Do you have Microsoft 365 or Office 2021? If so, remove the existing formulas, then enter the following formula in A5 on Quartal 1:

 

=FILTER('Gesamt Jahr'!A2:G50; ISTZAHL(SUCHEN("1"; 'Gesamt Jahr'!D2:D50)); "")

 

For Quartal 2, use "2" etc.