SOLVED

Subtotal Report Not Working

%3CLINGO-SUB%20id%3D%22lingo-sub-1412146%22%20slang%3D%22en-US%22%3ESubtotal%20Report%20Not%20Working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1412146%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Folks%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20trying%20to%20use%20the%20Subtotal%20Report%20in%20Excel%2C%20assuming%20I%20have%20the%20right%20thing.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20data%20I%20have%20is%20very%20simple%2C%20in%20two%20columns.%20Column%20A%20is%20a%20list%20of%20names%2C%20and%20Column%20B%20is%20house%20points.%20As%20an%20example%20of%20the%20data%2C%20there%20are%2010%20rows%20with%20the%20same%20name%20in%2C%20but%20different%20house%20points%20in%20each%20row.%20I%20want%20to%20subtotal%20the%20points%20against%20each%20name.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20run%20the%20report%2C%20and%20the%20subtotals%20I%20get%20are%20zero.%20I've%20set%20the%20change%20to%20be%20at%20the%20person's%20name%2C%20the%20function%20is%20Sum%2C%20and%20the%20subtotal%20is%20Points.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20what%20is%20wrong%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1412146%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1412164%22%20slang%3D%22en-US%22%3ERe%3A%20Subtotal%20Report%20Not%20Working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1412164%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F569472%22%20target%3D%22_blank%22%3E%40CMSCMSCMS%3C%2FA%3E%26nbsp%3BFixed%20it.%20There%20was%20something%20odd%20about%20the%20point%20data.%20It%20had%20the%20green%20triangles%20in%20the%20top%20left%20corner%2C%20although%20despite%20a%20bit%20of%20googling%20I%20couldn't%20find%20any%20clear%20information%20about%20what%20they%20signify%20other%20than%20an%20error%20(but%20this%20is%20just%20numbers%3F!).%20I%20copied%20the%20numbers%20to%20notepad%2C%20then%20copied%20them%20to%20a%20new%20spreadsheet%2C%20and%20now%20it%20works.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1412173%22%20slang%3D%22en-US%22%3ERe%3A%20Subtotal%20Report%20Not%20Working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1412173%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F569472%22%20target%3D%22_blank%22%3E%40CMSCMSCMS%3C%2FA%3E%26nbsp%3BApparently%20green%20triangles%20can%20signify%20numbers%20formatted%20as%20text%2C%20although%20I%20did%20change%20the%20formatting%20to%20numbers%20%F0%9F%A4%B7%E2%80%8D%3Amale_sign%3A%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1412188%22%20slang%3D%22en-US%22%3ERe%3A%20Subtotal%20Report%20Not%20Working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1412188%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F569472%22%20target%3D%22_blank%22%3E%40CMSCMSCMS%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYes%2C%20that's%20only%20an%20alert%20says%20the%20values%20which%20looks%20like%20numbers%20are%20saved%20as%20text.%20You%20may%20select%20them%20and%20from%20the%20icon%20drop-down%20menu%20convert%20to%20numbers%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22image.png%22%20style%3D%22width%3A%20235px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F193960iE82AAE9C1E41E6D3%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22image.png%22%20alt%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hi Folks,

 

I am trying to use the Subtotal Report in Excel, assuming I have the right thing.

 

The data I have is very simple, in two columns. Column A is a list of names, and Column B is house points. As an example of the data, there are 10 rows with the same name in, but different house points in each row. I want to subtotal the points against each name.

 

I've run the report, and the subtotals I get are zero. I've set the change to be at the person's name, the function is Sum, and the subtotal is Points.

 

Any ideas what is wrong?

 

Thanks 

3 Replies
Highlighted
Best Response confirmed by CMSCMSCMS (Contributor)
Solution

@CMSCMSCMS Fixed it. There was something odd about the point data. It had the green triangles in the top left corner, although despite a bit of googling I couldn't find any clear information about what they signify other than an error (but this is just numbers?!). I copied the numbers to notepad, then copied them to a new spreadsheet, and now it works.

Highlighted

@CMSCMSCMS Apparently green triangles can signify numbers formatted as text, although I did change the formatting to numbers 🤷‍

Highlighted

@CMSCMSCMS 

Yes, that's only an alert says the values which looks like numbers are saved as text. You may select them and from the icon drop-down menu convert to numbers

image.png