SOLVED

Structured Reference in diagram source

%3CLINGO-SUB%20id%3D%22lingo-sub-2799416%22%20slang%3D%22de-DE%22%3EStructured%20Reference%20in%20diagram%20source%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2799416%22%20slang%3D%22de-DE%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20issue%20that%20in%20previous%20used%20Office%202016%20I%20could%20use%20sttructured%20reference%20for%20getting%20the%20dynamically%20changing%20data%20of%20tables%20into%20my%20diagram.%20This%20was%20very%20helpful%20as%20the%20diagram%20automatically%20showed%20all%20the%20rows%20data%20and%20not%20just%20a%20static%20number%20of%20them.%20Now%20with%20Office365%20my%20structured%20reference%20get%20automatically%20replaced%20by%20the%20current%20static%20reference%20whenever%20I%20hit%20the%20apply%20button%20on%20the%20source%20selection%20for%20a%20diagram.%26nbsp%3B%3CBR%20%2F%3EAs%20I%20use%20diagrams%20in%20templates%20I%20do%20not%20want%20to%20put%20in%20a%20standard%20(always%20wrong)%20fixed%20number%20of%20rows%20for%20the%20diagram%20and%20then%20have%20to%20always%20adjust%20the%20source%20of%20every%20diagram%20in%20my%20file%2C%20whenever%20I%20use%20the%20template.%26nbsp%3B%3CBR%20%2F%3EFor%20better%20understanding%20I%20attached%20an%20example%20what%20happens%20to%20my%20structured%20reference%20when%20I%20click%20%22ok%22%20and%20reopen%20the%20source%20selection%20again.%3CBR%20%2F%3EIs%20there%20any%20solution%20for%20this%20issue%2C%20or%20did%20Microsoft%20just%20decide%20the%20once%20working%20structured%20reference%20for%20diagrams%20is%20not%20needed%20anymore%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222021-09-30_16h05_13.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F313964i26CC4E733891D5E8%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%222021-09-30_16h05_13.png%22%20alt%3D%222021-09-30_16h05_13.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%222021-09-30_16h04_51.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F313963iAE255CB947A14BF9%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%222021-09-30_16h04_51.png%22%20alt%3D%222021-09-30_16h04_51.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%E2%80%83%E2%80%83%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2799416%22%20slang%3D%22de-DE%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2799767%22%20slang%3D%22en-US%22%3ERe%3A%20Structured%20Reference%20in%20diagram%20source%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2799767%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1171310%22%20target%3D%22_blank%22%3E%40jake5691%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EEven%20if%20references%20are%20shown%20here%20they%20shall%20be%20automatically%20adjust%20if%20you%20change%20the%20table%20configuration.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2816762%22%20slang%3D%22de-DE%22%3ERe%3A%20Structured%20Reference%20in%20diagram%20source%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2816762%22%20slang%3D%22de-DE%22%3EIn%20Office%202016%20the%20references%20remained%20there%20and%20adjusted%20to%20changes%2C%20now%20it%20doesn't%20anymore%20in%20Office365.%20That's%20my%20issue%3C%2FLINGO-BODY%3E
New Contributor

Hi,

 

I have the issue that in previous used Office 2016 I could use sttructured reference for getting the dynamically changing data of tables into my diagram. This was very helpful as the diagram automatically showed all the rows data and not just a static number of them. Now with Office365 my structured reference get automatically replaced by the current static reference whenever I hit the apply button on the source selection for a diagram. 
As I use diagrams in templates I do not want to put in a standard (always wrong) fixed number of rows for the diagram and then have to always adjust the source of every diagram in my file, whenever I use the template. 
For better understanding I attached an example what happens to my structured reference when I click "ok" and reopen the source selection again.
Is there any solution for this issue, or did Microsoft just decide the once working structured reference for diagrams is not needed anymore?

2021-09-30_16h05_13.png2021-09-30_16h04_51.png

  

4 Replies

@jake5691 

Even if references are shown here they shall be automatically adjust if you change the table configuration.

In Office 2016 the references remained there and adjusted to changes, now it doesn't anymore in Office365. That's my issue

@jake5691 

Perhaps you may share some sample ? For example< I have such table

image.png

If I expand it Excel automatically expands data range

image.png

best response confirmed by jake5691 (New Contributor)
Solution

So I did some more digging and trying and my understanding now is that it works like pointed out by you, but doesn't work if your initial table has only one line of data. Because then the structured reference is not replaced by a series of cells but as a single cell reference. 
2021-10-07_11h14_48.png
So having one line of Data and adding more lines later does not result in expanding the series automatically. So my fix now is to have at least 2 lines of data in the initial table when creating the chart to bypass the issue of not expanding the series. Not a very nice/clear solution but it fixes my problem. Deleting the second row of data after the chart is created keeps the series alive, just creating the chart from only one line of data (with structured reference) doesn't work.

2021-10-07_11h15_14.png

Thank you @Sergei Baklan for your input, helped me to solve the issue!