Stockhistory Problem, #Blocked Error

New Contributor

Hello Gurus,

Got a problem with Stockhistory.  I'm using Office 365 desktop.  When I try to execute the function, it throws a #Blocked error.  The error has a note that says: "You're unable to view data types with your current privacy settings."  Searching MS Support I found this page:

which purports to show how to fix #Blocked errors.  It has specific instructions for the "privacy settings" error.  But following the instructions to change privacy settings has no effect.  I have logged out and back in after making setting changes.  Still no effect.  I made sure my Office version is up to date.  I also reviewed the other issues that can cause the #Blocked error and none of those appear to apply either.  I wasted the better part of an hour with tech support, but they were useless.  Actually, they said that you guys knew the apps better than they did.  So ... anybody seen this before?  Any ideas on how to debug the error?  Any suggestions much appreciated!


4 Replies
Update: I found the problem. Will post this for anyone who may run into the same glitch. I just systematically went through and disabled every privacy setting I could find (ie - no privacy limitations).
The one that made it work was in Account/Account Privacy Settings: Connected Experiences: "Let Office analyze your content to provide you with improvements." Yeah, doesn't sound like it would have anything to do with Stockhistory, but when I clicked the check box to enable this option, it cleared the #Blocked error and Stockhistory is now working fine.


would appreciate more help if your can.  Stockhistory worked earlier today.  Now it is blocked error.  I attempted to do what you described above but cannot get to a screen that shows that option to enable or disable.  Can you please provide more instruction  Thanks

Yes, please help. I have the same issue with this #BLOCKED in STOCKHISTORY Function.
Glad if share the solution for this. Thanks a lot in advance.


I don't have 365, I have the full app on my computer. I get exactly the same issue, #BLOCKED. There is a way to get to this, through File > Preferences > Privacy > Manage Content Experiences, and then there are 3 check boxes. On mine, all were checked to permit everything. The second check is entitled "Turn on experiences that download online content". There is a link below it that goes to this page and says if I have this checked, STOCKHISTORY content should be available... All were already checked, so STOCKHISTORY should have worked. Tried toggling off, quit app, re-opened, toggled back on, still #BLOCKD. Sadly, MSVader has created an Imperial blockade. Help me Obi-Wan, you're my only hope!

Here is that link to say it should work if it helps: