=SOM wont work

%3CLINGO-SUB%20id%3D%22lingo-sub-2638935%22%20slang%3D%22en-US%22%3E%3DSOM%20wont%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2638935%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20I%20try%20%3DSOM(A1%3AA10)%20I%20get%20this%20error%20%23NAME%3F%20Can%20someone%20help%20me%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2638935%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2639020%22%20slang%3D%22en-US%22%3ERe%3A%20%3DSOM%20wont%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2639020%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1126652%22%20target%3D%22_blank%22%3E%40MerijnRT%3C%2FA%3E%26nbsp%3BLooks%20like%20you%20are%20using%20an%20English%20Excel%20version.%20Use%20SUM%20in%20stead.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2639041%22%20slang%3D%22en-US%22%3ERe%3A%20%3DSOM%20wont%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2639041%22%20slang%3D%22en-US%22%3EAre%20you%20trying%20to%20make%20a%20summarization%20of%20values%20in%20cells%20in%20Excel%3F%20In%20English%20Excel%20the%20function%20name%20is%20SUM%20not%20SOM.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2639059%22%20slang%3D%22en-US%22%3ERe%3A%20%3DSOM%20wont%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2639059%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3BSo%20it%20works%20for%20me.%20But%20without%20the%20excel%20file%2C%20I%20can%20only%20guess%20and%20I%20don't%20want%20to.%3C%2FP%3E%3CP%3ETry%20%3D%20SUMPRODUCT%20(H1%3A%20H55)%2C%20it%20should%20work%20without%20a%20problem.%3C%2FP%3E%3CP%3EIf%20not%2C%20please%20insert%20a%20file%20(without%20sensitive%20data).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eformula%20in%20English%26nbsp%3B%20%3D%20SUMPRODUCT%20(H1%3A%20H55)%3C%2FP%3E%3CP%3Eformula%20in%20Netherlands%20%3DSOMPRODUCT(H1%3AH55)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20would%20be%20happy%20to%20know%20if%20I%20could%20help.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENikolino%3C%2FP%3E%3CP%3EI%20know%20I%20don't%20know%20anything%20(Socrates)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E*%20Kindly%20Mark%20and%20Vote%20any%20reply%20if%20it%20helps%20please%2C%20as%20it%20will%20be%20beneficial%20to%20more%20Community%20members%20reading%20here.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1126652%22%20target%3D%22_blank%22%3E%40MerijnRT%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2639208%22%20slang%3D%22en-US%22%3ERe%3A%20%3DSOM%20wont%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2639208%22%20slang%3D%22en-US%22%3EAlso%20check%20that%20the%20cell%20contains%20numbers%20and%20not%20text.%20Check%20all%20cells%2C%20look%20for%20extra%20spaces.%3CBR%20%2F%3ECheck%20the%20dataype%20is%20set%20to%20%22Numbers%22%20or%20%22General%22%20in%20the%20cells%2C%20not%20%22Text%22.%3CBR%20%2F%3EYou%20can%20also%20use%20the%20function%20%3DISNUMBER(cell)%20to%20check%20the%20content%20of%20the%20cells.%3C%2FLINGO-BODY%3E
Occasional Visitor

When I try =SOM(A1:A10) I get this error #NAME? Can someone help me?

5 Replies

@MerijnRT Looks like you are using an English Excel version. Use SUM in stead.

Are you trying to make a summarization of values in cells in Excel? In English Excel the function name is SUM not SOM.

 So it works for me. But without the excel file, I can only guess and I don't want to.

Try = SUMPRODUCT (H1: H55), it should work without a problem.

If not, please insert a file (without sensitive data).

 

formula in English  = SUMPRODUCT (H1: H55)

formula in Netherlands =SOMPRODUCT(H1:H55)

 

I would be happy to know if I could help.

 

Nikolino

I know I don't know anything (Socrates)

 

* Kindly Mark and Vote any reply if it helps please, as it will be beneficial to more Community members reading here.

@MerijnRT

Also check that the cell contains numbers and not text. Check all cells, look for extra spaces.
Check the dataype is set to "Numbers" or "General" in the cells, not "Text".
You can also use the function =ISNUMBER(cell) to check the content of the cells.

@Anna-Karin Petrusson But SUM will not result in a #NAME? error if the range contains text. It just returns zero or whatever the sum of the real numbers in the range would be, that is, as long as the range itself doesn't contain cells with errors.