Slicers not appearing in excel for office 365

Copper Contributor

So I have a workbook with multiple pivot tables, all from the same data source.  I'm trying to insert a slicer, however after I select the items I'd like to filter on from the options box that pops up and hit ok, nothing ever appears.  


Has anyone else ever dealt with this issue before?  Is this an issue with the version of office I'm using?  I'm curious what could be causing this to happen.


Thank you all for your help,


5 Replies
Hi Charles,

If you open the Selection pane (the looking-glass drop-down button on the Home tab), does it show the slicers?
Hi Jan, yes I’ve checked, unfortunately nothing shows up there either.
Weird. If you copy one of the pivots to a freshly inserted sheet, can you add the slicers there? If so, perhaps you can then copy the slicers to the tab where you need them?
Unfortunately I’ve tried that one too, no luck.

@ have the same issue.. slicer were working showing yesterday, but not working... i delete them. and n ow when i click on insert slicer nothing happens.

i have tried in new fresh pivot, and have the same issue.