Slicer not updating when source data is updated

Copper Contributor



I have a dashboard showing project data with multiple pivot tables. There are two slicers that are connected to all the pivot tables, Project ID and Project Status, these used to update when the source data changed but this is no longer the case and still doesn't update after refreshing the data. E.g. The Project Status of Project LIB682 changed from Active to Closed in the source data, however, if I select 'Active' in the Project Status slicer, LIB682 still appears in the ID slicer where it used to be greyed out to show it is not active. 


I have tried refreshing data and deleted and re-added the slicers but neither of these worked. When I first created the dashboard everything worked and I've not changed anything so would assume it should still be working.



6 Replies

You need to clean PivotTable cache. Right click on it, PivotTable options, here


change "Number of items..." from Automatic on None, Ok and refresh.


Or add data to data model creating PivotTable and build it on data model.

@Sergei Baklan 

Thankyou, worked for me.

@MilroV2 , you are welcome

Thank you sir, it helped.

@Sergei Baklan  Hi.  I am having a similar issue with Slicer not updating when source data is updated in the query, specifically I added a new file w/ data to the query aggregator.  I tried your suggestion below w/o success.   I see the new data in the pivot table / query (from the newly added file) but not in the slicers.   If I create a entirely new pivot from the updated query tab then the slicers are updating correctly, however I do not want to recreate my pivot tables. thanks

post note.. now if I filter the new data in the pivot directly then I see the data in the respective slicer but it is "grayed out"  as if there is no data.   I can select the gray out slicer category to filter the pivot table.   Question:  How do I get the slicer to format the category to be the same "blue" as the other slicer categories (e.g. have data.)  Otherwise this will be confusing to the user.. categories with data vs no data.


If I unclick "visually indicate items with no data" then the issue go aways, however this seems not logical.. what am I missing here?