Rutas inesperadas de OneDrive en las formulas y nombres cuando se dispone del fichero en local.

Visitor

La cuestión es:

  • ¿Qué está tomando la decisión de cambiar las rutas?
  • ¿Puede conrolarse?

Descripción el caso:

Por una parte, hay un libro Excel, al que llamo Maestra, con macros y código vba, que contiene varios rangos.

Por otro lado, desde una hoja que se genera mensualmente, a la que llamaremos Mensual, se accede tanto a los rangos de Maestra como a código de Maestra.

 

AL generar Mensual, hay fórmulas de tipo: =BUSCARV(D2;Maestra.xlsm!CCMxConAesq[[Clave]:[TipoLoc]];7;FALSO)

Por ejemplo, el administrador de Nombres de Mensual muestra:

EduJGR_0-1643109660032.png

La ruta de acceso (OneDrive local) de Mensual es:  :  C:\Users\pp\OneDrive\Documentos\ff\ll\mm\2021\04

La ruta de acceso (OneDrive local) de Maestra es  C:\Users\pp\OneDrive\Documentos\DocsLocal\kk

 

Estas rutas inesperada e incontroladamente se transforman en “formato web”, del tipo

https://d.docs.live.net/cea0000c99eeb888/Documentos/ff/ll/mm/yy/zz/Mensual.xlsm 

De la misma forma, las fórmulas se transforman en el tipo:

=BUSCARV(D2;'https://d.docs.live.net/cea0000c99eeb888 /Documentos/DocsLocal/kk/Maestra.xlsm'!CCMxConAesq[[Clave]:[TipoLoc]];7;FALSO)

 

Y Excel no es capaz de resolver los nombres y las fórmulas resulta ne error (Ref!).

Si se ‘da marcha atrás',  reemplazando la ruta de maestra en todas las fórmulas y en todos los nombres…

 

Verificada la configuración de OneDrive:

  • marcado 'Guardar espacio y descargar archivos a medida que los utiliza'.

En el Administrador de ficheros están marcados como

  • "Mantenerlo siempre en este dispositico" y tienen el icono en verde oscuro y con check de 'ok'....

 

 

1 Reply