ROUNDUP Function not working

Copper Contributor

roundup will not work on my computer but the same formula works on other computers & mobile. 

also the comma is not showing up on my computer but is everywhere else.

Picture #1 is computer 

Picture #2 is mobile

BrodieLaw_1-1610030153660.png             BrodieLaw_2-1610030220589.png


17 Replies


What is the list separator on your machine? If Windows


control international

Additional settings


Thanks for the help! This worked just had to change it back to a comma.

@Sergei Baklan 

@BrodieLaw , glad to help

Your answer didn't work for me @Sergei Baklan what could I be doing wrong?


Could you please give more details - what is the formula exactly and under "not work" do you mean some error message or result you don't expect.

Yes, I get the normal "There's a problem with this formula" message... What I need to achieve is that if a resultant answer has a decimal, I need it to round up to the NEXT whole number. Not the NEAREST whole number. So if the answer is 11.32, I need it to round up to 12. @Sergei Baklan 

This is the error I'm getting. The normal roundup formula isn't working.




In your screenshot, comma is the decimal separator.

So you should use semicolon between the arguments of the function:


Hans, this worked perfect! Thanks a million!

@Urban_Champion Hi. Round up is not working at all on my PC. The formula does not have a separator between the number and the rounding digits.



A comma gives the error as in the picture above. Please help


What happens if you use semicolon ; instead of comma?

Hi @Hans Vogelaar. Still the same




Press the Windows key+R to activate the Run dialog.

Type control international and press Enter or click OK.

Click Additional settings...

This is what I see on my PC:


What is the Decimal symbol on your computer?

And what is the Digit grouping symbol?

And the List separator?


Try to open attached file, it has nothing but


and check how formula looks like in your environment.

Hi @Hans Vogelaar. This is how the settings look.



Hi @Sergei Baklan. Everything looks to be fine now after I opened your file. Even the separator between in the formula is appearing now. 



Thank you for being so helpful.


On your computer, the list separator is the same as the decimal symbol: you use comma for both. That causes the conflict.

Either use comma as decimal symbol and semicolon as list separator, or point as decimal symbol and comma as list separator.

Thank you @Hans Vogelaar.  I correct this.