Radio Option Buttons Both Selecting When Put in Group Box

New Contributor

Working in an excel sheet where individual items need to be identified as belonging to one of two groups (Option A and Option B), my radio buttons within my group box are both selecting and I cannot get them to behave in an "either-or" situation.

My process is this: I create an group box, and then add my option buttons. Before renaming the option buttons, I resize them to fit within the group box. I then rename them. There is no clipping on the name text so it doesn't matter for my purposes. I then proceed to click one or the other. I have done this successfully twice. The third time, the radio buttons both accepted a "checked" input simultaneously. 

I have no idea what is going on. I deleted the option box, recreated it, deleted the radio buttons, recreated them, put them in, made sure no cell was linked, and tried again. They both, again, allowed a "checked" input. 

I tried tying one and then both options to a cell to see if that would help. It did not, and actually cause both cells to become tied. The moment you selected one, the other was selected. 

I am doing this in Form Control since I have heard that ActiveX can cause some problems and be a little more unwieldy. 

4 Replies

@Nathaniel_Polley 

Very sorry. "Both option buttons become tied." Not both cells. 

@Nathaniel_Polley did you figure this out? I am having the exact same problem. I've never had an issue before today and now all of a sudden a workbook that was working properly is messed and I have no idea what happened or how to fix it.

@BillyMitch 

I am not having this problem...yet.  My issue is I can't create a grouping of Radio Buttons.  I first create the Group Box and then add the Options Buttons, but when I move the Group Box the Radio Buttons stay put and don't move with the Group Box.  All I can think of is that there is a bug with my version of Microsoft Excel.

 

When using my work laptop that also has Excel I can complete the task without issue, but when using my personal computer at home I can't get it to work properly.  

 

Could your issue be that your version of Excel isn't loaded properly or corrupt?  I think that that is my problem.

I also faced the same problem, it was also the first problem I had and had to ask for help from everyone.

Listen to online radio here: internet radio hören