problema con la función si anidada

%3CLINGO-SUB%20id%3D%22lingo-sub-2343017%22%20slang%3D%22es-ES%22%3Eproblem%20with%20the%20function%20if%20nested%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2343017%22%20slang%3D%22es-ES%22%3E%3CP%3EI'd%20like%20to%20know%20what%20mistake%20I'm%20making%20when%20doing%20the%20%22if%20nested%22%20function.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E*%20for%20example%20I%20want%20to%20make%20the%20function%20%22if%20nested%22%20in%20a%20cell%20I%20evaluated%20these%20five%20scenarios%20in%20this%20table%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22dbravog_0-1620697569389.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F279699i3C3C8AE39BAA3EC3%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22dbravog_0-1620697569389.png%22%20alt%3D%22dbravog_0-1620697569389.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2343017%22%20slang%3D%22es-ES%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2343961%22%20slang%3D%22en-US%22%3ERe%3A%20problema%20con%20la%20funci%C3%B3n%20si%20anidada%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2343961%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1050347%22%20target%3D%22_blank%22%3E%40dbravog%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EPuede%20usar%20una%20tabla%20y%20una%20f%C3%B3rmula%20como%20esta%3A%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22S0394.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F279748i27F56588769AEE83%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22S0394.png%22%20alt%3D%22S0394.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3ELa%20f%C3%B3rmula%20en%20F2%20es%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3DSUMAPRODUCTO((E2%26gt%3B%24A%243%3A%24A%247)*(E2-%24A%243%3A%24A%247)%2C%24C%243%3A%24C%247)%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EVer%20el%20libro%20de%20trabajo%20adjunto.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Quisiera saber cual es el error que estoy cometiendo al hacer la función "si anidada"

 

* por ejemplo quiero hacer que la función "si anidada" en una celda me evalué estos cinco escenarios de esta tabla 

 

dbravog_0-1620697569389.png

 

1 Reply

@dbravog 

Puede usar una tabla y una fórmula como esta:

S0394.png

La fórmula en F2 es

 

=SUMAPRODUCTO((E2>$A$3:$A$7)*(E2-$A$3:$A$7),$C$3:$C$7)

 

Ver el libro de trabajo adjunto.