SOLVED

Organizational account authentication disappeared when creating web query in Excel

Copper Contributor

Hi, I tried to create a query using web URL in excel (Get data -> From Web). The URL is an Excel macro-enabled workbook from our organization SharePoint, which I am the owner of. I used to be able to create a query using the same URL with no issue last time, but now I can't.

 

The reason I can't - the organizational account option no longer appears for authentication. I can't connect using any other way.

Lucy_Luo_0-1695368489678.png

 

What should I do to make it appear again? I tried clearing cache of the excel and restarting my laptop.

 

 

5 Replies

Hi @Lucy_Luo,

Here are some steps for troubleshooting you can try to make the organizational account authentication option appear again when creating a web query in Excel:

  1. Make sure that you are signed in to your Microsoft account with the same account that you used to create the macro-enabled workbook on SharePoint.
  2. Try clearing your browser's cache and cookies.
  3. Try using a different browser.
  4. Try launching Excel in Safe Mode. To do this, press and hold the Ctrl key while you double-click the Excel icon.
  5. Repair your Office installation. To do this, go to Control Panel > Programs > Programs and Features and select Microsoft Office from the list of programs. Then, click Change and select Repair.
  6. Uninstall and reinstall Microsoft Office.

 

  • Make sure that you have the latest version of Excel installed.
  • Make sure that your organization allows access to SharePoint from Excel.

Please click Mark as Best Response & Like if my post helped you to solve your issue.
This will help others to find the correct solution easily. It also closes the item.


If the post was useful in other ways, please consider giving it Like.


Kindest regards,


Leon Pavesic

best response confirmed by Lucy_Luo (Copper Contributor)
Solution

@Lucy_Luo 

Try to use the link without /:x:/r

image.png

For example, if that's Excel file - one which you find in File->Info->Copy path (without ?web=1 at the end)

 

Thank you Sergei! I removed the /:x:/r and it works now!

@Lucy_Luo I solved it. Steps:
Data -> Queries & Connections
Edit your query in Power Query Editor

Data source settings

Clear permissions

Close

Close & Load

And you could see again the Organizational account option.

1 best response

Accepted Solutions
best response confirmed by Lucy_Luo (Copper Contributor)
Solution

@Lucy_Luo 

Try to use the link without /:x:/r

image.png

For example, if that's Excel file - one which you find in File->Info->Copy path (without ?web=1 at the end)

 

View solution in original post