notes attached to cells not visible, broken since last excel update (Office 365 on Mac)

Copper Contributor

I've got many notes (the yellow non-threaded formerly called comments) in my excel sheets. Since the latest software update I can not display/view my notes anymore.

The cells containing note still show the red triangle-mark, but the note does not show up when I mouse over. By clicking "show all notes" in the ribbon menu, it will just only show the connection lines between cell and invisible note rectangle. But I can not access view or even edit the notes.

Also right click on the cell -> edit note does not show anything.


is there a fix or at least a workaround existing?





macos: high sierra,

excel (office 365) version 16.21.1 (190123)

23 Replies

I have just discovered the same issue.  No option to add or edit notes either ... only comments (which I don't need).

I have same issue.  It looks like MS was nudging users off the old yellow notes feature (which I use a LOT) toward the "comments" side-bar approach.  I hate it when developers get a "good idea" and force us to change, especially with no notice or transition support.  This is a HUGE pain.  But, will MS notice?  I doubt it.

I have faced this problem recently.

Only "Delete Note" option is available in context menu.

If you want to add a new note, please go to the Review menu, the Note option is listed there.


I have had this problem too.  What I found worked was to copy the cell to a new tab.  The Note will show up there (though I had to move the frame buttons to make the square visible).  Then I copied the cell back to the original tab.  This fixed the issue for me.  Hope this helps.

@Carol Van Valkenburg 


Update:  I realize this is an old thread, but I 'Unhid' all the rows.  After I did that, I was able to right click and edit the notes.


I am using a PC but have been having a very similar issue.  I have discovered that when I open my SS I can hover over the red triangle and the Note contents will show.  But, as soon as I access a hyperlink... and return to my SS... the Note will no longer display when I hover.  My only work around is to close and then re-open my SS.

I have reported this twice.  But, so far... no response.


I went into - review - notes - drop down and selected "convert to comments"

There will be a column that will open and as you select the cell where the note/comment is, the comment box will be highlighted...

Not what we want like before, be that sort of works.

Thanks @simmed 


Actually, I reported the problem to Microsoft.  Then a couple weeks ago I received an email saying I had a private message from them.  I could never find the message.  But, then I noticed the problem was fixed.  I can now hover over and view the contents of the note.  Even after I have accessed a hyperlink.  I then remembered that there was a MS update a few days previous to the email from MS.  So, maybe that was the fix.  Not sure.  But it works now.  So, I am happy!!

I know this post is old, but we just had this issue. We're on Windows 10 Pro, with Microsoft 365. The line for the note was visible, but nothing suggested here worked for us. My coworker decided to click and drag to the right on the line, basically like it was a textbox collapsed and IT WORKED. The note was there, just squished into one line on the left.
I have dozens of yellow sticky Notes on each of my Excel worksheets. None of them displays upon mousing over. This is been going on for several months. There are no lines drawn to squished notes - I am familiar with that situation. The notes simply do not appear, rather they flash on and off a Split Second when the mouse hovers. I do not see why I need to go to some panel click to show notes in order to read these what happened to the old-fashioned way of having them come up upon mousing? And yes, I have the proper setting in Options Advanced ...display on Hover. Running 365, and have the latest updates.
Follow up to my above complaint:
Despite MS setting automatically to Update 365 as needed, and my running the update again a day or two ago, I since discovered a slew of uninstalled updates in a list - buried by MS somewhere out of sight... named "NON-ESSENTIAL" or similar... These dated back a couple of YEARS. Downloaded and Installed them, Restart, etc. -- Notes now appear upon mouse hover ~~ Additionally, the frequent interminable waits to Save - Excel "Not Responding" seem to have ceased.
Lesson learned - look for MS's Uninstalleds and put them in...
that's terrible. I have same problem. I put some critical data as notes in the forms of comments and they are not accessible in my new computer with office 2013, I upgraded to 2016, not better.

Hello. My first post here.
I have the same problem of an invisible note, but it only affects one cell in my spreadsheet. Just as others have described, there's a red triangle in the upper righthand corner of the cell, and when I attempt to view the note, a call-out line from the cell appears, but no note at the end of the line. I've tried the various suggestions outlined above, but none of them can get the note to appear. All my other cell notes are behaving properly.

The fact that only one cell is affected, not the entire SS makes me wonder if it's corrupted, rather than reflective of a global issue with an MS update. Running on a PC under Windows 10.

I have figured out the root cause of the problem I have experienced, I don't know whether it will apply to everyone with the similar problems:
Starting from Office 2016 and Office 365 Microsoft changed the way comments worked on the cells. New commenting feature has additional features like replying and resolving to comments called "threaded comments". The problem is that you can't see these comments using an earlier version of Office, in my case Office 2013 pro. I suspect even you have a compatible office version you need to be sign in to office 365 with a Microsft account. The thing is, you can actually see and just can't, but since you can't edit the document you can't resize the comment popup window so that you can see the rest of content (your comment). The reason is Microsoft  alters your document puts a reminder in before each of your comments that says “you can actually read the comment but not edit bla bla ”, but this reminder is the only thing visible unless you resize that window which you can't. So the actual content of the comment is unreadable.


The option/solution which does not have this problem for newer versions of Office is: commenting by not choosing “insert comment” but “new note” in the context menu of a cell. Unlike the earlier versions of office this classical way of doing things is renamed from "insert comment" to "new note". So when you use the new office and excel for the first time, you unsuspectingly comment with the "new comment" tool but it's a new thing that does not work as the old comment feature and practically you can't see the contents, and definitely can't edit with earlier versions and un-signed-in office 365 versions. You need to use “new comment”  to avodi future headaches and to be able to see it when using earlier versions of office and un-signed-in office 365 Excel.

In my opinion this is blunder for Microsfot which was the champion of backward compatibility.


edit: you can resize the comment window and see the rest of the comment and your content with office 2013 but you can realize this after days of frustration. You still cant see the content if you are not signed in to office 365.. 


Thanks for all the info, but here's what happened:
I clicked the icon "Show comments" in the Ribbon, and got a message in the sidebar pane: "There are no Comments in this file." This is not surprising, since I always use "New Note" rather than "Comment."


Then I went back and re-read a post from earlier in this thread: I selected the errant cell, then hit "Edit Note" in the ribbon. That brought up the callout line, terminating in an invisible note. At that point I was able to grab the "stem" line and stretch it open (sort of like pulling down a window shade), and voila! There was my Note. The problem I ran into previously was that simply clicking the affected cell brought up the "stem" line, but the instant I moved the Plus-shaped cursor out of the cell in an attempt to grab the stem line, the line disappeared! The way to evoke the stem line and make it stay on screen is to click "Edit Note" in the Ribbon.


So I eventually got there. Thanks to all for your help!!

@Jim6373My issue is that "edit notes" does nothing on any cell in one particular column that has cells with notes. No stem lines, no notes appearing, no nothing.  The column has different formatting on different rows -- it is not a consistently formatted column. The formatting is similar to adjacent columns that are not having this issue -- notes show fine in the adjacent columns. Very bizarre that this one column would not show notes when I click 'edit notes'.


The only way to see my notes in that column is to select "show/hide all notes", in which case the dozens of notes I have all appear at once in a jumbled mess. I have all updates installed and rebooting did not help.

@opieandy123456 I found that copying and pasting the cell to a blank cell, then cutting and pasting it back to the original cell allows me to edit after getting the symptoms you were having.  Just a workaround, but better than closing and opening the file (which doesn't work for me anyway).



How do you go about finding the uninstalled features? This seems to be the simplest, most broad way of restoring comments but after digging in the files for a while I'm coming up empty. 



In my case it turned out that the Note textbox changed it's dimensions and reduced the height to pixel = 1. That's the reason why I saw only the arrows.

Here's what I did to fix it:

1. Right Click on the affected cell --> Show/Hide Note (to have the arrow visible on the screen)

2. Right Click on the affected cell --> Edit Note

3. Zoom in so you can see the very thin hairline that looks to be note textbox.

4. Click on it so the little resizing points appear on the screen.

5. Drag one of them down so the Note appears.


Hope this helps!