SOLVED

Nested if and funtions

New Contributor

Hi first of all my name is Rui and i'm here with a problem that i could not solve . i would like to do an instruction to verify the text inside 2  cells and if the text assume 2 descriptions then i combined them and give a specific output. the instruction just with one verification works fine but when i try to do the four combinations that i need i cannot make it happen in any way. only with just 2 verifications will not work any help here by the experts Thank you people. i leave here my code :

The instruction starts with SE, SE is IF but in portuguese language.

Cell A values LONG or SHORT 

Cell B values Positive/ negative if no combination is matched then write Neutral

=SE(E(C3="LONG";D3="Positive");"+"; "Neutral") Works fine

=SE(E(D3="LONG";E3="Positive");"+"; "Neutral");SE(E(D3="SHORT";E3="Positive");"+"; "Neutral") don't work. I check the logic value and the return valuer if true or if false and the instruction is performing what should but returns #Value. 

 

3 Replies
best response confirmed by Sergei Baklan (MVP)
Solution

@gasoiline 

=IF(AND(D3="LONG";E3="Positive"),"+",IF(AND(D3="SHORT";E3="Positive"),"+","Neutral"))

=SE(E(D3="LONG";E3="Positive");"+";
 SE(E(D3="SHORT";E3="Positive");"+";"Neutral"))

 

@Juliano-Petrukio 

Thank you Juliano it works fine and as supposed to. i look to your expression and i was trying to follow the logic value plus value if true , value if false in every separated if and that way seems that does not work. only works  like you send me where the value if false output as the second IF connected. Thanks  i was getting furious with the code :).

Any time. Just remember to flag it as solved and smash the like button.