Need formula

%3CLINGO-SUB%20id%3D%22lingo-sub-2774377%22%20slang%3D%22en-US%22%3ENeed%20formula%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2774377%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%20Need%20formula%20excel%26nbsp%3B%20to%20count%20of%20winning%20games%2C%20for%20example%2013-2%2C%203-13%2C%20and%2013-8%26nbsp%3B%20games%20won%20is%202.%26nbsp%3B%20Thank%20you%20for%20the%20correct%20formula.%20Cell%20ranges%20are%20D3%20tot%20N3%20Gr%20Henk%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2774377%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2774531%22%20slang%3D%22en-US%22%3ERe%3A%20Need%20formula%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2774531%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1163447%22%20target%3D%22_blank%22%3E%40Henk66%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAs%20an%20array%20formula%20confirmed%20with%20Ctrl%2BShift%2BEnter%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3DSUMPRODUCT(--(IFERROR(LEFT(D3%3AN3%2CSEARCH(%22-%22%2CD3%3AN3)-1)-MID(D3%3AN3%2CSEARCH(%22-%22%2CD3%3AN3)%2B1%2C10)%2C0)%26gt%3B0))%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hello, Need formula excel  to count of winning games, for example 13-2, 3-13, and 13-8  games won is 2.  Thank you for the correct formula. Cell ranges are D3 tot N3 Gr Henk 

4 Replies

@Henk66 

As an array formula confirmed with Ctrl+Shift+Enter:

 

=SUMPRODUCT(--(IFERROR(LEFT(D3:N3,SEARCH("-",D3:N3)-1)-MID(D3:N3,SEARCH("-",D3:N3)+1,10),0)>0))

Found =AANTAL.ALS(D3:N3;"13*") and working Thanx Hans

@Henk66 

That will work if a game/match is always won by reaching 13 points. The formula that I posted is more general, it also works for football games or baseball games.

@Henk66 you should really consider @Hans Vogelaar suggestion because I don't know what game you are tracking but in many/most you will have tie breaker situations 13-15 or 16-14 if it is win by 2, both of which will give you a wrong answer using your 13* search