Issue with Goal Seek suddenly not working - June 6, 2021

%3CLINGO-SUB%20id%3D%22lingo-sub-2420533%22%20slang%3D%22en-US%22%3EIssue%20with%20Goal%20Seek%20suddenly%20not%20working%20-%20June%206%2C%202021%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2420533%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20suddenly%20having%20an%20issue%20with%20Goal%20Seek%20not%20working%20correctly.%26nbsp%3B%20I%20have%20successfully%20used%20it%20many%2C%20many%20times%20in%20the%20past%20and%20cannot%20begin%20to%20figure%20out%20what%20has%20happened.%26nbsp%3B%20The%20issue%20first%20came%20to%20light%20within%20a%20spreadsheet%20much%20to%20complicated%20to%20describe%20here%20but%20I%20created%20a%20new%20workbook%20with%20just%20this%20limited%20data%20to%20illustrate%20the%20issue.%26nbsp%3B%20Cell%20A1%20%3D%201.%26nbsp%3B%20Cell%20A2%20%3D%202.%26nbsp%3B%20Cell%20A3%20%3D%208.%26nbsp%3B%20Cell%20A4%20%3D%20Average(A1%3AA3)%2C%20which%20correctly%20shows%20as%203.66667.%26nbsp%3B%20Now%2C%20I%20run%20Goal%20Seek%20and%20tell%20it%20to%20set%20cell%20A4%20to%20a%20value%20of%2010%20by%20changing%20cell%20A2.%26nbsp%3B%20Rather%20than%20Goal%20Seek%20iterating%20on%20cell%20A2%20to%20determine%20the%20value%20of%2021%20necessary%20in%20that%20cell%20to%20achieve%20a%20value%20of%2010%20in%20cell%20A4%2C%20it%20iterates%20cell%20A4%20and%20eventually%20%22finds%22%20a%20solution%20of%2010%20in%20A4.%26nbsp%3B%20So%2C%20it%20has%201.)%20iterated%20on%20the%20wrong%20cell%20and%202.)%20replaced%20my%20%3Daverage(A1%3AA3)%20formula%20in%20cell%20A4%20with%20a%20value%20of%2010.%26nbsp%3B%20What%20is%20going%20on%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20attaching%20screen%20grabs%20of%20the%20before%20Goal%20Seek%2C%20the%20Goal%20Seek%20setup%2C%20and%20the%20after%20Goal%20Seek.%26nbsp%3B%20(Note%2C%20in%20the%20'after'%20screen%20grab%2C%20A4%20still%20shows%20to%20be%20a%20formula%20equal%20to%20%3DAverage(A1%3AA3)%20but%20that%20is%20just%20because%20I%20had%20not%20closed%20the%20Goal%20Seek%20window%20yet.%26nbsp%3B%20Once%20that%20is%20done%2C%20the%20formula%20is%20replaced%20by%20the%20number%2010.%26nbsp%3B%20The%20replacement%20occurs%20even%20if%20I%20click%20Cancel%20which%20would%20normally%20forget%20the%20Goal%20Seek%20results%20and%20revert%20the%20cell%20that%20was%20iterated%20on%20back%20to%20its%20original%20value.)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20Microsoft%20Office%20Professional%20Plus%202019%2C%20Excel%20version%202105%2C%20Build%2014026.20246.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20in%20advance%20for%20any%20assistance%20on%20this%20very%20odd%20issue%20that%20is%20driving%20me%20crazy.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBrian%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2420533%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2420669%22%20slang%3D%22en-US%22%3ERe%3A%20Issue%20with%20Goal%20Seek%20suddenly%20not%20working%20-%20June%206%2C%202021%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2420669%22%20slang%3D%22en-US%22%3ESure%20looks%20strange.%20I%20cannot%20replicate%20the%20problem%20with%20Microsoft%20365%20Apps.%20Goal%20Seek%20changes%20A2%20to%2021%20and%20A4%20still%20contains%20the%20AVERAGE%20formula%20with%20a%20calculated%20value%20of%2010.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2895532%22%20slang%3D%22en-US%22%3ERe%3A%20Issue%20with%20Goal%20Seek%20suddenly%20not%20working%20-%20June%206%2C%202021%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2895532%22%20slang%3D%22en-US%22%3EiDon't%20see%20anything%20wrong%20with%20it!%20You%20want%20the%20average%20to%20be%2010%20by%20changing%20the%20cell%20A2%20-%20The%20value%20in%20Cell%20A2%20Is%2021%20and%20then%20the%20avegrage%20of%201%2B%2012%20%2B%208%20%3D10%20which%20is%20exactly%20what%20Goal%20seek%20does%20if%20you%20use%20shortcut%20ALT%20D%20W%20G%3C%2FLINGO-BODY%3E
New Contributor

I am suddenly having an issue with Goal Seek not working correctly.  I have successfully used it many, many times in the past and cannot begin to figure out what has happened.  The issue first came to light within a spreadsheet much to complicated to describe here but I created a new workbook with just this limited data to illustrate the issue.  Cell A1 = 1.  Cell A2 = 2.  Cell A3 = 8.  Cell A4 = Average(A1:A3), which correctly shows as 3.66667.  Now, I run Goal Seek and tell it to set cell A4 to a value of 10 by changing cell A2.  Rather than Goal Seek iterating on cell A2 to determine the value of 21 necessary in that cell to achieve a value of 10 in cell A4, it iterates cell A4 and eventually "finds" a solution of 10 in A4.  So, it has 1.) iterated on the wrong cell and 2.) replaced my =average(A1:A3) formula in cell A4 with a value of 10.  What is going on?

 

I am attaching screen grabs of the before Goal Seek, the Goal Seek setup, and the after Goal Seek.  (Note, in the 'after' screen grab, A4 still shows to be a formula equal to =Average(A1:A3) but that is just because I had not closed the Goal Seek window yet.  Once that is done, the formula is replaced by the number 10.  The replacement occurs even if I click Cancel which would normally forget the Goal Seek results and revert the cell that was iterated on back to its original value.)

 

I am using Microsoft Office Professional Plus 2019, Excel version 2105, Build 14026.20246.

 

Thank you in advance for any assistance on this very odd issue that is driving me crazy.

 

Brian

7 Replies
Sure looks strange. I cannot replicate the problem with Microsoft 365 Apps. Goal Seek changes A2 to 21 and A4 still contains the AVERAGE formula with a calculated value of 10.
iDon't see anything wrong with it! You want the average to be 10 by changing the cell A2 - The value in Cell A2 Is 21 and then the avegrage of 1+ 12 + 8 =10 which is exactly what Goal seek does if you use shortcut ALT D W G

@Donald_Genes  ....  This is an old thread, so I don't know why you are responding -- and with an unconstructive comment, at that ("I don't see anything wrong with it").

 

But in another thread, a user claimed to trace the root cause to a particular add-in.  He wrote:  ``The error appears to be with MorningStar Office's add-in. I disabled it and it worked just fine.``

 

Unfortunately, I did not record the link to the thread.  If I find it again, I will amend this response.

 

And I don't know if that is the only add-in that causes this problem.  I'd be surprised if it were, because we see this problem posted "often".

@Joe User...thank you for the response.  I have no add-ins loaded so that is not the issue.  Not sure what is going on as the issue now seems to come and go, but always manifests in the same way.

@u144175  wrote: ``I have no add-ins loaded so that is not the issue``

 

Well, that's too bad.  Since we have never been able to duplicate the problem, I had hoped it was that simple.

 

Also, it is too bad that the problem is intermittent for you.  That means that if we suggest an experiment and the problem "goes away", we cannot say with impunity that it worked around the problem.  The problem might return.

 

When you say that it "comes and goes", do you mean with the same data and formulas?  Or with different data and/or formulas? 

 

If the problem was consistent with the example in your original posting, and now it "comes and goes" with __that__ example, do you have any idea what changed?

 

And how often do you get bit by the problem?  Hopefully often enough that if we suggest an experiment and the problem goes away "long enough" -- comes back "soon enough" after stopping the experiment, we can say with some confidence that the experiment points to the root cause?

 

Have you ever seen the problem using Solver instead of Goal Seek?  If not, is there any reason not to use Solver instead?

 

(It would be nice to understand the root cause of the problem.  But I suspect that is not __your__ primary interest.)

 

Finally, if you have an example that misbehaves in this way consistently or "most of the time", you might try starting Excel in safe mode and see if the problem "never" appears.  Close all windows (*).  Press __and_hold__ the Ctrl key, then click an Excel __program__ icon (not a file icon).  You should get a yes-or-no prompt to continue in safe mode.  Click yes.  In Excel, click on Open to open the Excel file in safe mode.

 

-----

(*) Close all windows because otherwise, we cannot see the yes/no safe mode prompt. (sigh)

It comes and go with different data / workbooks. When I first experienced the issue, it was within a large workbook I use virtually every day. That's when I created the simple example sheet I provided in my original post above to illustrate the situation. A week or two later, the issue went away and goal seek was working correctly again. Everything seemed ok until about a week ago and then I once again saw the same behavior, this time in a workbook that I only use occasionally (about once a month). Different workbook but same incorrect goal seek behavior. I did not attempt to use solver instead of goal seek. Goal seek is presently working again so any troubleshooting is moot right now however I will try solver and safe mode if/when I again see the aberrant goal seek behavior. Thanks for the suggestions on this very odd, intermittent issue. I do appreciate the help.

@u144175  wrote:  ``then I once again saw the same behavior, this time in a workbook that I only use occasionally (about once a month)``

 

Rats!  Check astronomical tables for phases of the moon, alignment of planets, position of stars in zodiacal signs, solar flares, etc.  Just kidding!

 

I usually find that "intermittent" problems are not as random as they might appear.  Eventually, we recognize a pattern that points to a deterministic explanation.

 

Good luck!

 

PS.... One other variable to consider: automatic updates of Office 2019?  I disable all automatic updates whenever possible.  But IIRC, that is not possible with Office 365 -- which is why I avoid it like the plague.  I don't know about Office 2019.  I think MSFT has changed the notion of "standalone" software nowadays.  (sigh)