SOLVED

Insertion de caractères

New Contributor

Bonjour,

Je recherche une formule pour insérer des traits d'union dans une série de chiffres.

Ex. : 1234567890 deviendrai 123-456-7890

Merci de votre aide

NatZ51

3 Replies
best response confirmed by NathalieZ51 (New Contributor)
Solution

@NathalieZ51 

=LEFT(B7,3)&"-"&MID(B7,4,3)&"-"&RIGHT(B7,4)

 

Maybe with this formula. An alternative could be flashfill.

Hello,
I copied the formula in the collumn I added and change the B7 for my cell #, unfortunatly it doesn't work.
What did I do wrong...
Thanks again for your help...
Thanks for your help,
I fynally found it
=TEXTE(A2;"[<=9999999]###-####;###-###-####")
Thanks again have a great day!