IFS function not working

Copper Contributor



I recently brought a spreadsheet over to a new laptop and the IFS statements that I had been using are no longer recognized. I get the #NAME? error in all cells that are currently using them.


Please advise on how to fix this. Thanks. 

39 Replies

Dear Aaron,


IFS function is only available for Office 365 subscribers, it came to Excel with January 2016 updates for Office 365. Follow the below link:

IFS Function


Make sure that you have Office 365 subscription with version 1601 (Build 6568.2025) and above!


If you have in your new laptop an earlier version of Excel or Excel 2016 as a one-time purchase, it is normal to see the #NAME? instead of IFS function, because it's not defined in these versions of Excel.


Hello Haytham,
I am using office 365 (through my office MAC laptop) and also having the same error. I am using Excel version 16.16.1

In general shall work


Perhaps some other reason. If you attach sample file we may check if it works on other platform.

Hi Fred,


The Excel team says that this function is now available in the latest update to Excel for Mac (version 16.x).

Please read this announcement.


Please make sure you have the latest Excel update and verify your Office 365 subscription.
If the problem still exists
, please send feedback to Microsoft or ask this community as it's the best place to get support.


Hope that helps

I have attached the sample file from a tutorial i am learning. Please see column F (Age Group). I have also included a screen grab showing details of my Excel version and the excel sheet showing the error.screen-grab.jpg



It seems that you have no Office 365 subscription as I don't see anything in About Excel Form indicates that you have an Office 365 subscription.

Hello Haytham,
I work for an S&P 500 company, and our Office 365 subscription comes included in our devices(including SharePoint online). When working remotely I check my work mails/outlook through office 365 online. My Excel comes as part of the office subscription

Hi Fred,


Could you please check if attached works on your computer.



I have checked and the excel sheet shows the result of the formula you inputted. I copied and passed your formula into a larger version of the excel sheet I was using, but it came up with the same #NAME error.



Your initial formula looks like this


What I actually did that's click on formula bar, IFs is converted to IFS and returns result.


If in addition press Enter correct formula will be populated on entire column.


Not sure why that happens, formulas are not case sensitive and column is formatted as General. But I did that on Windows desktop.


Our IT team switch me from office 365 to excel pro 2016 and I’m having these problems with existing spreadsheet that have IFS formulas. What can I do

Please help me, my IFS function is not working. 




why do i always get's a 4 result ?

Hi Jim,


Replace IFS on nested IF or wait for a build where IFS appears.

Hi Tour,


That's separate topic, better to start new conversation in such case.


As for the function, IFS works till first TRUE condition. If E13 is -10 it's definitely less than -2.5, condition TRUE and formula returns 4/

Hey I figured it out my self after 2 hours...


I've had to switch the other way around...


start from the smallest first


and it's working


yes, exactly

IFS does not work in my Excel 2016 even though the help page says it does.  It is not listed in the functions.

Thank you @SergeiBaklan .  I just installed the Office 365 version and now it works.