i don't have countif in my excel

Occasional Contributor

Hi , I want to use The Countif function but this error is appear 

AbdelilahBzm_0-1642500166266.png

 

this how I use the function : =countif(B2:B50,100)

and I have microssoft office 2016

10 Replies

@AbdelilahBzm 

Perhaps you shall use semicolons instead of commas as separator, please check your regional settings.

@AbdelilahBzm 

Your formula works fine on my computer but, then, I have an English language version of Excel with comma as the parameter separator..

= NB.SI(B2:B50;100)

  If you are using a French language version wouldn't something like the above be more appropriate?

 

Thank you for your response,

I tried to change my regional settings but I didn't find the path in my excel as in the support Microssoft ( Click File > Options > Regional Format Settings)

Thank you for your response,
I tried the change "," with ";" and the response that I got is : #NOM?

@AbdelilahBzm 

That is progress. The indications are that your version of Excel is set to French. Is that what you want? If not, I would turn to @Sergei Baklan or @Riny_van_Eekelen for help because they will be more familiar than I with moving between their native language, the localisation language of their computers and English (or, more precisely, American English).

@Peter Bartholomew Not really my cup of tea either. Since the first day I laid hands on a computer I've "driven" English only. Feel very uncomfortable when I have to use a computer set-up in Dutch (the language I've grown up with) or Swedish (the language I "live" with). It feels completely alien. Like driving a car in England :))

 

 

@AbdelilahBzm 

In general you don't need to change your default regional settings. You need to use formulae as they are in your language. If you are not sure and know English formula, you may translate it here Translator • Excel-Translator

It gives for

image.png

result

image.png

However, you eventually may not use default regional setting. They are here

Win+R

control international

ok

Additional settings

Check List separator here

image.png

If Excel language is French but List separator is changed on comma, formula will be

=NB.SI(B2:B50,100)

If Excel language is English but you are on default List separator (semicolon), formula will be

=COUNTIF(B2:B50;100)

Thank you for your help it worked with "=NB.SI(B2:B50,100)" ,
and for the site https://en.excel-translator.de/
Your formula is working thank you

@AbdelilahBzm , you are welcome