how to insert a row at another place which I had cut

Occasional Contributor

In order to move a particular row say row number 10, above the row number 4,  need to cut the row number 10 and insert it above the row number 4, what should I do or which functionality of excel will help me to perform this function

10 Replies



Assuming your rows are arranged in an orderly fashion, preferably as a Table (column headings, consistent types of data in each column, etc), it should be fairly easy to use Data....Sort.   If there's no column specifically attuned to your exact desired order--you don't say WHY you might want what's now in row 10 to be moved to row 4--you could always add another column with numbers in them, from 1 to 10 (or whatever) and make sure that the one you want in row 4 carries the number 4.


If none of that makes sense, perhaps you could post a copy (devoid of any personal or private information) so it could be demonstrated with your actual spreadsheet.

@pratimabeli If it is just cutting one row and pasting it above another is what you need, thus no other logic that could be solved by, e.g. sorting in a table, try the following:


Select row 10 and right-click. Select "Cut" from the pop-up menu.

Screenshot 2020-07-11 at 05.56.47.png

Now select row 4 and right-click. Select "Insert cur Cells"

Screenshot 2020-07-11 at 05.57.41.png

This will then have cut out the content of the original row 10 and placed it above the original row 4.

Screenshot 2020-07-11 at 06.03.59.png

The same result can be achieved by drag-and-drop. Select row 10 and aim the mouse pointer over its edge until you see a four-arrow-headed plus sign. Press and hold Shift, click, drag and drop the row into its required destination.


@Riny_van_Eekelen . Thank you very much for this . But the point is that when I select the row number 10 and right click, the "Cut" option from pop up menu is shown grayed out.


Even when I select row 10 and use Control "X" and then select row 4 and right click, even the "Insert Cut Cell" option is again shown grayed out here also.


With the help of technical person from Microsoft helpline, I have checked all the settings, even repaired the MS office but still problem is persisting.

@pratimabeli  There are a number of reasons that it could be grayed out, which you may have already checked.  Is the sheet or workbook protected, are there merged cells, is there an object, ...   It would be best if you could share the workbook for us to see.  Another thought is can you select row 4 and 'insert row'?  that would be helpful info to know also and if you can then can you select some cells and copy/cut and paste?

@mtarler  Thanks for the response. Please note that neither the sheet nor the work book is protected. None of the cells is merged nor any object is there. I have removed all such things i.e passwords, merger of cells etc.

I have tried to selected row 4, right click but again the insert option in popup menu is grayed out.


Similarly if I select a single cell, right click, only copy option is available which I can select and paste the value any where. But here again the "Cut" option is grayed out. 


As requested, I have attached the workbook here for your views.


Alo for me the sheet works without problems ... for safety I have unlocked all cells ... maybe the problem comes from there.
Enclosed the file with the unlocked cells and the path to it.

Path: Select cell or area.
Right mousekey
Format cells
Remove the locked hook



I would be happy to find out if I could help.



I know I don't know anything (Socrates)


@pratimabeli , Both techniques @Riny_van_Eekelen mentioned work for me without any issue. 

Still no success. I would be happy to have workbook where you could perform the requisite action. Further  as mentioned you in the email I got, did not find any video showing them in action.  

Best Response confirmed by pratimabeli (Occasional Contributor)

@pratimabeli  , it was just the file you uploaded. Here's the video of the drag and drop holding the shift key down...

Thanks a lot. The problem has been resolved and now I can perform "cut" and "insert cut cell" activities by selecting row (or even column) and dragging the same to desired place by using shift key.


However I am still unable to understand the reason for the "cut" option being grayed out from drop menu when I right click the mouse after selecting a row. Earlier some time back this functionality was working.


Even I had repaired "Microsoft Office Home and student 2016" which I had installed and using for all such MS office applications.