How do I change "#VALUE!' or at least stop it from showing?

%3CLINGO-SUB%20id%3D%22lingo-sub-3467870%22%20slang%3D%22en-US%22%3EHow%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3467870%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20set%20up%20an%20Invoice%20template%20in%20XL.%20In%20the%20template%20I%20can%20a%20select%20a%20%22product%22%20in%20a%20cell%20(e.g%20C1)%2C%20and%20the%20price%20of%20the%20product%20per%20unit%20is%20automatically%20shown%20in%20another%20cell%20(e.g%20F1).%20Finally%20in%20another%20cell%20(e.g%20cell%20I1)%2C%20I%20can%20add%20the%20amount%20of%20product%20used.%3C%2FP%3E%3CP%3EIt%20will%20then%20total%20up%20to%20the%20correct%20amount%20in%20(eg%20Cell%20J1)%3A%20So%20far%20so%20good%3A%20all%20works!%3C%2FP%3E%3CP%3EThe%20issue%20I%20need%20to%20address%20is%20if%20I%20don't%20use%20a%20product%20and%20leave%20C1%20blank%2C%20J1%20displays%20%22%23VALUE%22.%3C%2FP%3E%3CP%3EHow%20can%20I%20format%20J1%20to%20display%20either%20the%20currency%20symbol%2C%20or%20a%20blank%20cell%2C%20if%20there%20is%20no%20input%20in%20C1%3F%3C%2FP%3E%3CP%3E(If%20I%20change%20the%20formula%20in%20J1%20to%20use%20cell%20B1%20instead%20of%20C1%2C%20J1%20displays%20the%20currency%20symbol%20only%20(not%20%22%23VALUE%22!)%3C%2FP%3E%3CP%3E(Didn't%20have%20this%20issue%20with%20XL%20from%20Office%2010%3A%20I%20merely%20copied%20the%20template%20over!)%3C%2FP%3E%3CP%3E%26nbsp%3BMany%20Thanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3467870%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EBI%20%26amp%3B%20Data%20Analysis%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExcel%20for%20web%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20Scripts%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETraining%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3467887%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3467887%22%20slang%3D%22en-US%22%3EI%20think%20you%20should%20check%20the%20below%20error%20definition%20site%20because%20as%20per%20microsoft%20%23value%20happens%20when%20%3A%20%22There's%20something%20wrong%20with%20the%20way%20your%20formula%20is%20typed.%20Or%2C%20there's%20something%20wrong%20with%20the%20cells%20you%20are%20referencing.%22%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Fhow-to-correct-a-value-error-15e1b616-fbf2-4147-9c0b-0a11a20e409e%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Foffice%2Fhow-to-correct-a-value-error-15e1b616-fbf2-4147-9c0b-0a11a20e409e%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468001%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468001%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F425238%22%20target%3D%22_blank%22%3E%40Icemankool%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYou%20may%20hide%20it%20with%20IFERROR()%2C%20but%20since%20everything%20works%20on%20Excel%202010%20and%20doesn't%20work%20on%20Excel%20365%20I'd%20check%20formulae%20carefully%20if%20they%20are%20correct%20for%20the%20modern%20Excel.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468002%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468002%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1197336%22%20target%3D%22_blank%22%3E%40jitinm%3C%2FA%3E%26nbsp%3BYes%20but%20No!%20It%20always%20used%20to%20be%20(with%202010)%2C%20if%20C1%20was%20left%20Blank%2C%20then%20the%20currency%20symbol%20only%20would%20display%20(no%20value)%20in%20J1.%20Not%20anymore%2C%20and%20this%20is%20what%20I%20am%20trying%20to%20achieve.%3C%2FP%3E%3CP%3EJust%20to%20reiterate%2C%20the%20issue%20doesn't%20exist%20in%26nbsp%3B%20there%20is%20%22input%22%20at%20C1.%3C%2FP%3E%3CP%3EI%20would%20think%20there%20would%20be%26nbsp%3B%20a%20conditional%20formatting%20resolution%20for%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3BAt%20the%20moment%20I%20am%20on%20a%20%22work%20around%22%20by%20using%20B1%20as%20a%20cell%20rather%20than%20C1%20(B1%20has%20text!).%26nbsp%3B%20I%20don't%20obtain%20any%20%22%23VALUE!%22%20messages%20in%20J1%20when%20I%20do%20this%2C%20although%20one%20would%20think%20there%20would%20be!.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468021%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468021%22%20slang%3D%22en-US%22%3EThanks%20Sergei%3A%20The%20spreadsheet%20actually%20uses%20different%20cells%20to%20those%20I%20mentioned%20(though%20t%20it%20would%20be%20easier%20to%20explain).%20The%20Actual%20is%20this%3A%20Formulae%20in%20Cell%20J34%20is%20%3DF34*I34.%3CBR%20%2F%3EWhere%20I34%20is%20the%20amount%20of%20product%20used%20and%20F34%20is%20the%20price%20per%20unit%20of%20product.%3CBR%20%2F%3EF34%20uses%20an%20%22IF%22%20based%20on%20C34%20(%3DIFC34%3D%20%22SAND%22%2C%20%22%C2%A310%22%2C%20IF%20C34%20%3D%22CEMENT%22%2C%20%22%C2%A35.00%22%20etc)%20so%20if%20I%20put%20sand%20in%20C34%20and%200.2%20in%20I34%2C%20J34%20will%20correctly%20show%20%C2%A320.%3CBR%20%2F%3EThe%20issue%20is%20only%20occurs%20when%20I%20leave%20C34%20blank%20(F34%20is%20%22automatic%20because%20of%20the%20IF%20function).%3CBR%20%2F%3EWhen%20I%20input%20a%20product%20into%20C34%2C%20but%20omit%20a%20quantity%20in%20I34%2C%20I%20just%20get%20the%20currency%20symbol%20in%20J34.%20This%20is%20what%20I%20am%20trying%20to%20achieve%20when%20C34%20is%20left%20blank.%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468027%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468027%22%20slang%3D%22en-US%22%3EI%20think%20the%20error%20is%20because%20of%20the%20symbol%20typed%20in%20the%20formula.%20Maybe%20you%20should%20use%20it%20under%20the%20format%20instead%20of%20the%20formula.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468029%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468029%22%20slang%3D%22en-US%22%3EWhich%20symbol%3F%20(Please%20see%20my%20Reply%20to%20Sergei)%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468030%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468030%22%20slang%3D%22en-US%22%3EPound%20%22%C2%A3%22%20%3A-%20(%3DIFC34%3D%20%22SAND%22%2C%20%22%C2%A310%22%2C%20IF%20C34%20%3D%22CEMENT%22%2C%20%22%C2%A35.00%22%20etc)%20.%20I%20tried%20to%20replicate%20it%20in%20the%20excel%20and%20it%20is%20showing%20%23value%20error.%20When%20I%20removed%20it%20worked%20just%20fine.%20Instead%20you%20should%20use%20currency%20symbol%20in%20the%20format%20cell%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468032%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468032%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1197336%22%20target%3D%22_blank%22%3E%40jitinm%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468033%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468033%22%20slang%3D%22en-US%22%3EThe%20issue%20seems%20to%20be%20with%20the%20%22if%22%20list%20function.%3CBR%20%2F%3EIf%20I%20merely%20type%20figures%20into%20f34%20and%20i34%2C%20then%20it%20doesn't%20matter%20which%20cell%20is%20left%20blank%2C%20there%20is%20no%20%22%23value!%22%20notification%20in%20J34%2C%20and%20J34%20will%20only%20display%20the%20currency%20symbol.%20For%20this%20test%2C%20F34%20has%20not%20been%20%22IF'd%22!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3468055%22%20slang%3D%22en-US%22%3ERe%3A%20How%20do%20I%20change%20%22%23VALUE!'%20or%20at%20least%20stop%20it%20from%20showing%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3468055%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F425238%22%20target%3D%22_blank%22%3E%40Icemankool%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EPrice%20in%20formula%20shall%20be%20the%20number%2C%20not%20text.%20Result%20is%20formatted%20as%20pounds%20applying%20Accounting%20format.%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22image.png%22%20style%3D%22width%3A%20574px%3B%22%3E%3Cspan%20class%3D%22lia-inline-image-display-wrapper%22%20image-alt%3D%22image.png%22%20style%3D%22width%3A%20574px%3B%22%3E%3Cimg%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F377604i6A91D34F935C3566%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22image.png%22%20alt%3D%22image.png%22%20%2F%3E%3C%2Fspan%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3EPlease%20check%20attached%20file.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I've set up an Invoice template in XL. In the template I can a select a "product" in a cell (e.g C1), and the price of the product per unit is automatically shown in another cell (e.g F1). Finally in another cell (e.g cell I1), I can add the amount of product used.

It will then total up to the correct amount in (eg Cell J1): So far so good: all works!

The issue I need to address is if I don't use a product and leave C1 blank, J1 displays "#VALUE".

How can I format J1 to display either the currency symbol, or a blank cell, if there is no input in C1?

(If I change the formula in J1 to use cell B1 instead of C1, J1 displays the currency symbol only (not "#VALUE"!)

(Didn't have this issue with XL from Office 10: I merely copied the template over!)

 Many Thanks

10 Replies
I think you should check the below error definition site because as per microsoft #value happens when : "There's something wrong with the way your formula is typed. Or, there's something wrong with the cells you are referencing."

https://support.microsoft.com/en-us/office/how-to-correct-a-value-error-15e1b616-fbf2-4147-9c0b-0a11...

@Icemankool 

You may hide it with IFERROR(), but since everything works on Excel 2010 and doesn't work on Excel 365 I'd check formulae carefully if they are correct for the modern Excel.

@jitinm Yes but No! It always used to be (with 2010), if C1 was left Blank, then the currency symbol only would display (no value) in J1. Not anymore, and this is what I am trying to achieve.

Just to reiterate, the issue doesn't exist in  there is "input" at C1.

I would think there would be  a conditional formatting resolution for this?

 At the moment I am on a "work around" by using B1 as a cell rather than C1 (B1 has text!).  I don't obtain any "#VALUE!" messages in J1 when I do this, although one would think there would be!.

Thanks Sergei: The spreadsheet actually uses different cells to those I mentioned (though t it would be easier to explain). The Actual is this: Formulae in Cell J34 is =F34*I34.
Where I34 is the amount of product used and F34 is the price per unit of product.
F34 uses an "IF" based on C34 (=IFC34= "SAND", "£10", IF C34 ="CEMENT", "£5.00" etc) so if I put sand in C34 and 0.2 in I34, J34 will correctly show £20.
The issue is only occurs when I leave C34 blank (F34 is "automatic because of the IF function).
When I input a product into C34, but omit a quantity in I34, I just get the currency symbol in J34. This is what I am trying to achieve when C34 is left blank.
I think the error is because of the symbol typed in the formula. Maybe you should use it under the format instead of the formula.
Which symbol? (Please see my Reply to Sergei)
Pound "£" :- (=IFC34= "SAND", "£10", IF C34 ="CEMENT", "£5.00" etc) . I tried to replicate it in the excel and it is showing #value error. When I removed it worked just fine. Instead you should use currency symbol in the format cell
The issue seems to be with the "if" list function.
If I merely type figures into f34 and i34, then it doesn't matter which cell is left blank, there is no "#value!" notification in J34, and J34 will only display the currency symbol. For this test, F34 has not been "IF'd"!

@Icemankool 

Price in formula shall be the number, not text. Result is formatted as pounds applying Accounting format.

image.png

Please check attached file.