How can I use the SUMIF tools if I get an error in the final result

Copper Contributor

 

Hi, i need help with this... i think had a mistake cause finally result is $0, someone can explain me what is the error? ... I want to collect the data discriminating according to the selection of the month and type column. I used the tools as follows:   =SUMAR.SI.CONJUNTO(Registro[MONTO];Registro[MES];$A$2;Registro[TIPO];"ingreso")

description formula

Record[AMOUNT]: blue
Record[MONTH]: red
Register[TYPE] green

 

thanks for your help and support

 

 

Captura.PNG

9 Replies

@Ximenaxen 

It looks like the MES column contains the abbreviated month name "ene".

Option 1: change this so that it contains the fill month name "enero"

Option 2: change A2 to "ene" instead of "enero".

Option 3: change the formula to

 

=SUMAR.SI.CONJUNTO(Registro[MONTO];Registro[MES];IZQUIERDA($A$2;3);Registro[TIPO];"ingreso")

thanks for your help, that was the error @Hans Vogelaar 

@Hans Vogelaar Hi hans, i have a new problem.... the tools SUMIF when i used them on the table the datas was appears disorganized and i don´t know why?cause when I used them in the table previos I used the same tools and the same order and no error came out, can you help me?

 

I used the tool as follows:

=SUMAR.SI.CONJUNTO(registro[PRESUPUESTO];registro[MES];$B$2;registro[CONCEPTO];N14)

 

 

 

Captura.PNG

@Ximenaxen 

Could you attach a small sample workbook demonstrating the problem (without sensitive data), or if that is not possible, make it available through OneDrive, Google Drive, Dropbox or similar?

@Ximenaxen 

If you wish, you can attach the workbook to a private message to me (click on my user picture)

@Ximenaxen 

The formula should refer to N16 instead of N14.

You can clear the cells below (O17:O35) and refer to N16#:

 

=SUMAR.SI.CONJUNTO(registro[PRESUPUESTO];registro[MES];$B$2;registro[CONCEPTO];N16#)

thanks for your help but maybe thats not the problem. In this case the error wasn´t solucionate

@Ximenaxen 

Can you explain what is wrong with the attached workbook?