funcion anidada

Occasional Visitor

tengo 2 formulas que aplican sobre una misma colunmna de datos ,

1-por una parte una funcion sumar si de acuerdo a condicones  que se deben cumplir y

2-otra funcion de sub total para que me entregue el subtotal de la misma  columna .

 

necesito anidar estas dos formulas para que por una parte me sume  las celdas que cumplen la funcion marcadas con una x y por otra parte que me sume el subtotal si es que  hago un filto seleccionando determinados  terminos de alguna celda ( en este caso el nombre del cliente)

 

estas son las dos formulas 

 

=SUMAR.SI.CONJUNTO(U29:U7000;I29:I7000;"x")

 

=SUBTOTALES(9;U27:U7000)

 

 

1 Reply

@cphb6220 

You can use

 

=SUMPRODUCT(SUBTOTAL(9,OFFSET(U29:U7000,ROW(U29:U7000)-MIN(ROW(U29:U7000)),,1)),--(I29:I7000="X"))

 

In Spanish:

 

=SUMAPRODUCTO(SUBTOTALES(9;DESREF(U29:U7000;FILA(U29:U7000)-MIN(FILA(U29:U7000));;1));--(I29:I7000="X"))