SOLVED

Função/Formula para identificar palavras ou letras de frases

New Contributor

Gostaria de saber alguma lógica que identifica letras ou palavras de uma frase e caso encontra essas letras ou palavras retorne um valor definido por mim, segue o exemplo abaixo:

joaosantos60_0-1661866944289.png

Coluna "N documento (principal)" é a coluna que tem o nome dos documentos de um projeto 

coluna "Formato' é a coluna que quero colocar a lógica de identificar qual o formato de cada documento.

 

Funcionamento da lógica: 

 

Se o documento for  "FD" (Independente do que vier após isso na frase) o documento tem o formato A4, então na coluna "Formato" e na linha correspondente do documento deve aparecer "A4".

Outro exemplo, se o documento for um "RM" (Independente do que vier após isso na frase) o documento tem o formato A3, então na coluna "Formato" e na linha correspondente do documento deve aparecer "A3".

 

Gostaria de saber que é a fórmula que devo usar para conseguir realizar esse trabalho.

3 Replies
best response confirmed by joaosantos60 (New Contributor)
Solution

@joaosantos60 

Crie uma lista com as letras e formatos e nomeie-a como Lista:

S1711.png

Você pode então usar uma fórmula como

 

=SEERRO(PROCV(ESQUERDA(N2; 2); Lista; 2; FALSO); "")

 

(N2 é a célula com o nome do documento)

Muito obrigado, deu certinho obrigado!
Única coisa que eu tive que mudar, foi que em vez de fazer apenas uma única lista eu fiz duas listas, mas funcionou do mesmo jeito.