formule SI imbriqué

Occasional Visitor

Bonjour

Je veux réaliser une formule renvoyant la date de validité d'un test suivant sa date d'origne.

J' ai la date de réalisation du test en colonne F.

Si Date_Test< 31/12/2022 et >01/07/2021 alors validité 10 ans

Si Date_Test compris entre 01/01/2013 et 01/01/2018 alors validité jusqu'au 31/12/2022

Si Date_Test compris entre 01/01/2018 et 01/07/2021 alors validité jusqu'au 31/12/2024

 

J'ai réaliser la formule suivante:

=SI(OU(F2<DATE(2012;12;31);F2>DATE(2021;6;30));DATE(ANNEE(F2)+10;MOIS(F2);JOUR(F2)-1);
SI(F2<DATE(2018;1;1);DATE(2022;12;31);DATE(2024;12;31)))

 

Cela me renvoi uniquement le résultat 31/12/2024.

 

Merci pour votre aide

1 Reply

@Benoit_Julhan 

=IF(AND(F2>DATE(2012,12,31),F2<DATE(2018,1,1)),DATE(2022,12,31),IF(AND(F2>DATE(2018,1,1),F2<DATE(2021,7,1)),DATE(2024,12,31),IF(AND(F2>DATE(2021,7,1),F2<DATE(2022,12,31)),DATE(YEAR(F2),MONTH(F2),DAY(F2))+DATE(10,1,0),"date en dehors de la plage de validité")))

 

Is this the formula you are looking for?