Formule incorrecte

Copper Contributor

Bonjour,

Lorsque j'entre la formule ci-dessous, un message d'erreur apparaît. Or, après avoir cherché maintes et maintes fois, je ne parviens pas à trouver où se trouve l'erreur. Pouvez-vous m'aider s'il vous plaît ?

=SI([@Date]=””;””;RECHERCHEX(MOIS([@Date]);Listes!$C$2:$C$13;Listes!$D$2:$D$13))

Je vous remercie.

7 Replies

Bonjour,

 

Ta formule me semble correcte.

Quel est le message d'erreur (fenêtre pop-up, #VALEUR, #NOM....) ?

Ton poste utilise bien les points-virgules pour séparer les arguments et non les virgules ?

 

@Anne-FlorenceT 

@Hecatonchire merci de ton retour. Il semble que le message d'erreur porte sur la syntaxe du nom "Date". (capture-ci dessous). Or, j'ai tenté d'enlever le @ avant Date mais rien y fait.Oui c'est bien des points-virgules. 

Capture d’écran 2024-01-06 à 13.12.52.png

 

 

意味不明

Sur PC ça fonctionne

 

2024-01-06 13_22_06-part.xlsx - Excel.png

 

Pour être sur de [@Date], efface le dans la formule en ligne 2 puis clic sur la cellule  A2 pour que ce soit Excel qui génère la référence (il y a peut être un caractère invisible après le Date).

 

@Anne-FlorenceT 

@Hecatonchire c'est bizarre que pour toi ça fonctionne pourtant

Comme indiqué je pense que le problème vient du nom de la colonne A.

 

Tu as peut être "Date " et non "Date" par exemple (un espace à la fin).

 

Une solution pour vérifier cette supposition, ressaisie l'étiquette en A1.

 

@Anne-FlorenceT 

Bonjour, j'ai eu le même problème que vous. Pour ma part, ça s'est résolu en enlevant les "" et en les ressaisissant. On dirait que sur le nouvel office, ils soient légèrement différents. En espérant que ma réponse n'arrive pas trop tard.