Formule de calcul pour majorer les heures supplémentaires afin de suivre le contingent d'heures

%3CLINGO-SUB%20id%3D%22lingo-sub-2710924%22%20slang%3D%22en-US%22%3EFormule%20de%20calcul%20pour%20majorer%20les%20heures%20suppl%C3%A9mentaires%20afin%20de%20suivre%20le%20contingent%20d'heures%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2710924%22%20slang%3D%22en-US%22%3E%3CP%3EBonjour%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EJe%20souhaite%20r%C3%A9aliser%20une%20formule%20de%20calcul%20pour%20les%20heures%20suppl%C3%A9mentaires%20de%20mes%20collaboratrices%3C%2FP%3E%3CP%3Ela%20cellule%20du%20total%20d'heures%20va%20se%20nommer%20G10%3C%2FP%3E%3CP%3ELorsque%20le%20total%20d'heures%20est%20inf%C3%A9rieur%20%C3%A0%2035%20le%20logiciel%20doit%20prendre%20g10-35%20%3D%20-%20%3F%3C%2FP%3E%3CP%3ELorsque%20G10%20est%20sup%C3%A9rieur%20%C3%A0%2035h%20mais%20inf%C3%A9rieur%20%C3%A0%2039h%20le%20logiciel%20doit%20prendre%20(g10-35(%20*%201.10%20%3D%20%3F%3C%2FP%3E%3CP%3ELorsque%20G10%20est%20sup%C3%A9rieur%20%C3%A0%2039h%20mais%20inf%C3%A9rieur%20%C3%A0%2043h%20le%20logiciel%20doit%20prendre%20((g10-35)*1.1)%20%2B%20((43-g10)*1.25)%20%3D%20%3F%3C%2FP%3E%3CP%3ELorsque%20G10%20est%20sup%C3%A9rieur%20%C3%A0%2043h%20mais%20inf%C3%A9rieur%20%C3%A0%2048%20heures%20le%20logiciel%20doit%20prendre%20((g10-35)*1.1)%20%2B%20((43-39)*1.25)%20%2B%20((48-g10)*1.50)%20%3D%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPourriez%20vous%20m'aider%20%C3%A0%20%C3%A9tablir%20cette%20formule%20afin%20que%20tout%20se%20fasse%20automatiquement%20SVP.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2710924%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2711149%22%20slang%3D%22en-US%22%3ERe%3A%20Formule%20de%20calcul%20pour%20majorer%20les%20heures%20suppl%C3%A9mentaires%20afin%20de%20suivre%20le%20contingent%20d'heures%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2711149%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1144383%22%20target%3D%22_blank%22%3E%40Delphine_exco%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EEt%20si%20le%20total%20est%20sup%C3%A9rieur%20%C3%A0%2048h%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EPeut-%C3%AAtre%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3DSUMPRODUCT((G10%26gt%3B%7B35%2C39%2C43%2C48%7D)*(G10-%7B35%2C39%2C43%2C48%7D)*%7B1.1%2C0.15%2C0.25%2C0.25%7D)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2711288%22%20slang%3D%22fr-FR%22%3ERe%3A%20Calculation%20formula%20for%20increasing%20overtime%20to%20track%20the%20time%20quota%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2711288%22%20slang%3D%22fr-FR%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F127945%22%20target%3D%22_blank%22%3EVogelaar%20%40Hans%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUnfortunately%20this%20does%20not%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20we%20were%20to%20exceed%2048%20hours%20it%20would%20remain%20really%20exceptional%20and%20I%20would%20modify%20by%20hand.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Bonjour,

 

Je souhaite réaliser une formule de calcul pour les heures supplémentaires de mes collaboratrices

la cellule du total d'heures va se nommer G10

Lorsque le total d'heures est inférieur à 35 le logiciel doit prendre g10-35 = - ?

Lorsque G10 est supérieur à 35h mais inférieur à 39h le logiciel doit prendre (g10-35( * 1.10 = ?

Lorsque G10 est supérieur à 39h mais inférieur à 43h le logiciel doit prendre ((g10-35)*1.1) + ((43-g10)*1.25) = ?

Lorsque G10 est supérieur à 43h mais inférieur à 48 heures le logiciel doit prendre ((g10-35)*1.1) + ((43-39)*1.25) + ((48-g10)*1.50) = ?

 

Pourriez vous m'aider à établir cette formule afin que tout se fasse automatiquement SVP.

 

 

6 Replies

@Delphine_exco 

Et si le total est supérieur à 48h?

 

Peut-être

 

=SUMPRODUCT((G10>{35,39,43,48})*(G10-{35,39,43,48})*{1.1,0.15,0.25,0.25})

@Hans Vogelaar 

Malheureusement cela ne fonctionne pas.

 

Si on devait dépasser 48 h cela resterait vraiment exceptionnel et je modifierai à la main.

@Delphine_exco 

Pourriez-vous fournir un exemple du résultat souhaité pour chaque gamme de valeurs ? Merci d'avance.

@Hans Vogelaar 

 

Voici le détail que je souhaite calculer

si (g10<35; g10-35;si(35<g10>39;(g10-35)*1.1;si(39<g10>43;(39-35)*1.1+(g10-39)*1.25);si(g10>43;(39-35)*1.1+(g10-39)*1.25)

 

Je ne sais pas si cela est très clair.

@Delphine_exco 

Essayez

 

=SI(G10<=35; G10-35; SI(G10<=39; (G10-35)*1,1; SI(G10<=43; (39-35)*1,1+(G10-39)*1,25); SI(G10<=48;(39-35)*1,1 + (43-39)*1,25 + (48-G10)*1,50; "Plus que 48"))))

 

Mais est-il correct que le résultat sera négatif si G10<35? La formule suivante ma semble plus logique:

 

=SI(G10<=35; 0; SI(G10<=39; (G10-35)*1,1; SI(G10<=43; (39-35)*1,1+(G10-39)*1,25); SI(G10<=48;(39-35)*1,1 + (43-39)*1,25 + (G10-43)*1,50; "Plus que 48"))))

Oui c'est normal que le résultat soit négatif car les heures faites en moins viendront en déduction des heures faites en plus.