SOLVED

formulas not working

Frequent Contributor

hi,

 

each time i refresh this query, the formulas in D6:v6 stop working.

 

=SUMAR.SI.CONJUNTO(Hoja1!$K:$K;Hoja1!$G:$G;$O$6;$D:$D;">1";$C:$C;">"&S2;$C:$C;"<"&U2)

 

can someone tell me why??

 

Thank you very much, Juan

4 Replies
best response confirmed by juan jimenez (Frequent Contributor)
Solution

@juan jimenez 

Column D is formatted as Text, so the values are treated as text, not as numbers.

Select column D.

Set the number format to General.

On the Data tab of the ribbon, click Text to Columns, then click Finish.

See the attached version.

Thank you
On the Data tab of the ribbon, click Text to Columns, then click Finish.

Why is this needed??

@juan jimenez 

Just changing the number format to General won't change the values. Text to Columns will convert the text values to numbers.

Thank you very much for helping and teaching!