FILTER function on Excel for Mac

New Contributor

Hi,

I have the desktop app Microsoft Excel for Mac with Microsoft 365. According to the Microsoft website for the FILTER function, I should be able to use this function with my current license; however, I can't use it (I've tried typing '=FILTER(...' and tried searching in the Formula Builder accessed from the ribbon).

 

Is this because I am on Mac, or should I be able to use the function? Again, according to Microsoft it is supported on Excel for Microsoft 365 for Mac, so I'm not sure why it isn't working for me.

 

ar620360_2-1672629161254.png

ar620360_1-1672629068465.png

 

3 Replies

@ar620360 

 

It should indeed be working. I work on a Mac as well (for what it's worth, there is an update to the software, to 16.70, but I'm sure that's not the cause of your difficulties).

 

I've attached a very simple file, created at another time to illustrate how FILTER could work. If you open it it should function for you.

 

It may be that you're not using the correct syntax. So here also is a link explaining FILTER more fully; there's also a YouTube video available, which is where I first learned of it.

@mathetes, thanks for the reply.  I opened the file you created and it still is not working for me (see screenshots below of what I see). I updated my software yesterday, so my Microsoft AutoUpdate window currently shows that Excel is up-to-date at version 16.68.  Any clue why it is still not working?

 

Clicking on the formula for cell G5, before hitting enter to execute the formula.

ar620360_0-1672674706895.png

After hitting "control + shift + enter" to run the array formula. 

ar620360_1-1672674760133.png

I tried running the formula myself in cell G9 and get the message that "the function isn't valid".

ar620360_4-1672675379377.png

 

 

 

@ar620360 

 

Any clue why it is still not working?

 

The one thing I'd suggest--because something similar did happen to me recently with some other services I was supposed to have--I was told I had to go to the menu under Excel, the one at the very top of your screen, and select "Sign Out"

mathetes_0-1672684391169.png

 

And then close out of Excel, shut down the computer, turn it back on, and sign in again with your user name and password for the 365 Subscription. 

 

If that doesn't work, I'm out of ideas.