Filter Formula won't produce results

%3CLINGO-SUB%20id%3D%22lingo-sub-3181413%22%20slang%3D%22en-US%22%3EFilter%20Formula%20won't%20produce%20results%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3181413%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20attempting%20to%20build%20a%20table%20using%20Option%2FRadio%20buttons.%20I%20have%20built%20one%20table%20successfully%2C%20however%20I%20cannot%20get%20this%20FILTER%20formula%20to%20pull%20the%20correct%20data%20from%20my%20Master%20Table.%20Although%20I%20do%20not%20get%20an%20error%2C%20the%20formula%20just%20produced%200's%20where%20there%20should%20definitely%20be%20data.%20I%20used%20identical%20formulas%20and%20referencing%20to%20build%20a%20working%20FILTER%20formula%20so%20any%20suggestions%20as%20to%20the%20cause%20of%20this%20is%20appreciated.%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Capture02.17.PNG%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F349252iA05DD3E75F97F190%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Capture02.17.PNG%22%20alt%3D%22Capture02.17.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3181413%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExcel%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFormulas%20and%20Functions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3181516%22%20slang%3D%22en-US%22%3ERe%3A%20Filter%20Formula%20won't%20produce%20results%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3181516%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1310755%22%20target%3D%22_blank%22%3E%40dm2542%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-applescript%22%3E%3CCODE%3E%3DFILTER(BT3%3ABW55%3BBT2%3ABW2%3DERSTERWERT(CB1%3B1%3B%22Trailer%20Shipments%22%3B2%3B%22TB%20Shipments%22%3B3%3B%22Trailer%20Production%22%3B4%3B%22TB%20Production%22))%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3EThis%20formula%20seems%20to%20be%20the%20german%20translation%20of%20your%20formula%20and%20works%20well%20in%20my%20spreadsheet.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

I am attempting to build a table using Option/Radio buttons. I have built one table successfully, however I cannot get this FILTER formula to pull the correct data from my Master Table. Although I do not get an error, the formula just produced 0's where there should definitely be data. I used identical formulas and referencing to build a working FILTER formula so any suggestions as to the cause of this is appreciated.Capture02.17.PNG

2 Replies

@dm2542 

=FILTER(BT3:BW55;BT2:BW2=ERSTERWERT(CB1;1;"Trailer Shipments";2;"TB Shipments";3;"Trailer Production";4;"TB Production"))

This formula seems to be the german translation of your formula and works well in my spreadsheet. 

@dm2542 

Without FILTER().

=INDEX(BT3:BW14,,CB1)